Is there an easy way to transfer everything from Rhino 7 to Rhino 8?

Hi McNeel,

I mainly use Rhino 7 and would like to start moving my workflow over to Rhino 8, mainly to use PushPull. I’ve tried these steps, and did the OptionsExport/Import steps but I was wondering if there was a more streamlined way to move over to Rhino 8?

By move over, I mean I’d like to run a command, export a file or follow some straightforward process (i.e. akin to one that you’d follow when transferring to a new phone) such that once completed, when I open Rhino 8, I’ll find:

  • everything that I’ve changed in _Options (Aliases, display modes
  • all plug-ins from my Rhino 7 that are compatible installed (and ideally, a list of which plug-ins were incompatible and thus not installed)
  • my custom toolbars
  • template files

Basically, I’d like to find everything that I customised about Rhino 7 in Rhino 8 such that I can just switch out the app pinned to my taskbar, use the great new features or R8 and never look back.

I’m currently trying to do things manually, but in the event that the move to Rhino 8 ends up negatively impacting my workflow, I will opt to return to my more familiar Rhino 7 environment until I eventually need to use R8 again. At that point, I would hope to not have to manually update my Rhino 8 to work like my 7 again.

Scratch that, while writing this post, I realized this bug still exists: PopupToolbar flashes then disappears : RH-79373 ( which is something my workflow highly depends on. It’s nice to see that the MMB Popup Toolbar now works, but the fact that PopupToolbar still doesn’t work after more than half a year since release is really killing my motivation to transfer over.

Another bug that… bugs me is RH-79363.

Dunno, although the YouTrack bug report doesn’t state it’s closed/fixed, PopupToolbar seems to be working OK here…

Hmm alright, good to know. Let me see if my Rhino 8 is on the latest SRC.

Edit: It is, but for some reason, now it’s working! Will update if it breaks again.

Edit 2: It works intermittently. Broken again now. I’ll tinker around for a couple mins to see if it’s repeatable.

Yes, if you can repeat it it would be good to know how - I just tested a couple of things here because I don’t really use this function.

Okay, I’m able to repeat it.

Steps to reproduce:

  • Run _PopupToolbar standard to observe it working as expected
  • Run _Zoom Extents
  • Redo step 1 and observe it not working: flashes then disappears
System Info

Rhino 8 SR7 2024-4-30 (Rhino 8, 8.7.24121.13001, Git hash:master @ 44b9af795a5996a2a877659c9d5ef63b0da7ecfa)
License type: Educational, build 2024-04-30
License details: Cloud Zoo

Windows 11 (10.0.22621 SR0.0) or greater (Physical RAM: 16GB)
.NET 7.0.0

Computer platform: LAPTOP - Plugged in [100% battery remaining]

Hybrid graphics configuration.
Primary display: Intel(R) UHD Graphics (Intel) Memory: 1GB, Driver date: 7-8-2020 (M-D-Y).
> Integrated graphics device with 3 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port
Primary OpenGL: NVIDIA GeForce RTX 3070 Laptop GPU (NVidia) Memory: 8GB, Driver date: 4-11-2024 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 552.22
> Integrated accelerated graphics device with 4 adapter port(s)
- Secondary monitor is laptop’s integrated screen or built-in port

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 4-11-2024
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 8 GB

Rhino plugins that do not ship with Rhino
C:\Program Files\Cyberstrak\R7\CS_ModelingPlugIn.rhp “Cyberstrak Modeling PlugIn”
C:\Users\Anto\AppData\Roaming\McNeel\Rhinoceros\packages\8.0\DiscordPresence\\DiscordPresence.rhp “DiscordPresence”
C:\Users\Anto\AppData\Roaming\McNeel\Rhinoceros\7.0\Plug-ins\Bella (813de3fb-18eb-405f-bfcd-b0b4d3da91fb)\\bella_rhino.rhp “Bella”
C:\Users\Anto\AppData\Roaming\McNeel\Rhinoceros\packages\8.0\CommandTracker\8.0.0\CommandTracker.rhp “CommandTracker”
C:\Users\Anto\AppData\Roaming\McNeel\Rhinoceros\8.0\Plug-ins\KeyShot12RhinoPlugin (78243fe3-17a0-4865-b713-88b4c224c48c)\\KeyShot2023RhinoPlugin\Rhino 7\KeyShot2023RhinoPlugin.rhp “KeyShot12RhinoPlugin”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 8\Plug-ins\Commands.rhp “Commands” 8.7.24121.13001
C:\Program Files\Rhino 8\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 8\Plug-ins\SectionTools.rhp “SectionTools”
C:\Program Files\Rhino 8\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 8.7.24121.13001
C:\Program Files\Rhino 8\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 8.7.24121.13001
C:\Users\Anto\AppData\Roaming\McNeel\Rhinoceros\packages\8.0\PanelingTools\2021.3.2.446\PanelingTools.rhp “PanelingTools”
C:\Program Files\Rhino 8\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 8\Plug-ins\MeshCommands.rhp “MeshCommands” 8.7.24121.13001
C:\Program Files\Rhino 8\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 8\Plug-ins\RhinoCycles.rhp “RhinoCycles” 8.7.24121.13001
C:\Program Files\Rhino 8\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 8.7.24121.13001
C:\Program Files\Rhino 8\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”

EDIT: My reply could probably go in the thread below since I don’t want to de-rail the initial topic
Popuptoolbar command bug in Rhino8 - Rhino / Rhino for Windows - McNeel Forum

Post your steps to reproduce directly in that thread.