Is it a new Bug in GH 1 ? Split tree To divide curve!

grasshopper

(Mehrdad Y Mohajer) #1

hi everybody …
I worked in Gh 1 and practice a tutorial but in middle of practice when I want to connect the Split tree to divide curve an error occurred … and I think that its a bug?!

borj.gh (29.6 KB)


(David Rutten) #2

What is the error message you’re getting with that red component? It behaves as expected here.


(Mehrdad Y Mohajer) #3
  1. Solution exception:Object reference not set to an instance of an object.

(David Rutten) #4

Hmm, looks like a bug, but potentially one that has been fixed between your and my version. The list of curves you’re feeding into the Divide component has a lot of null values, does the error go away if you clean that data tree and remove all null values?


(Mehrdad Y Mohajer) #5

it’s Worked So So :slight_smile:
its Work in error too



(Mehrdad Y Mohajer) #6

unfortunately its not worked :thinking:


(Tim Stark) #7

Can’t look at the file, but maybe a curve has the length 0?


(David Rutten) #8

What exact Rhino version or build date are you on?


(Mehrdad Y Mohajer) #9

i think its was a last version … !
actuly . when i opend the tuterial file in GH too the problem is there yet .


(David Rutten) #10

It’s certainly fairly new. I myself use internal daily builds so I’m usually somewhat ahead of the curve, but I don’t think any code has changed on Divide Curve in several months.

Can you check one more thing? Disable the Parallel computing option on the Divide component, the two dots in the upper left corner of the component should turn into one dot. I don’t expect this is going to help, but that option represents the last time the code for that component was changed.


(Mehrdad Y Mohajer) #11

YES :+1:
By disabling the Parallel computing its seem that fixed.


(Mehrdad Y Mohajer) #12

thanx for answering.
NO the length is not 0.
the Parallel computing in divide curve was the problem.


(David Rutten) #13

Thanks, someone must have noticed an oversight and fixed it between your and my version. I’ve added some more null-checks just in case.