I have two identical surfaces opposing and intersecting each other at 90 degrees. They obviously are in the same plane and obviously appear to intersect yet using the trim or intersect command these are not recognized as intersecting. There exists a work around or two and I’ve had success with those but it still doesn’t address the fundamental problem. I am likely missing something but still need some advice out there.

intersection failure.3dm (4.5 MB)

Hello - I see there’s a problem here - I’m poking at it… thanks for the example.

use DivideAlongCreases check all and voila it splits and trims and all you need. did you by any chance merge the fillets without option smooth? or how did you create the profile, can you post the input curve?

I still got a funky intersection after dividing along creases here, so I left it as is for the bug report.


i get square dance intersections

But also some are missing, right? Here I also get one of the squares joined to the vertical… - bad object.


hmm nope right through the entire ding dong (at least on my old macbookpro), but the lower square is indeed joined into the leg. real square dance.

The input curves are totally straightforward. They consist of radii and linear curves. Nothing unusual there at all. I’ve done this sort of thing for a long time and am perplexed as this intersection problem has happened only a few times. I actually exported that intersection from a larger file, opened it on it’s own, checked for bad surfaces, found none and still could not intersect , trim or boolean union. My intent was to have the two pieces of trim join at a 90 degree corner on the top surface of a hanging locker, bureau, chest of drawers and the like. The work around was easy: Setting ortho as an option with 45 degrees, I drew a orthogonal curve away from the corner of the object that the trim would rest upon, then drew a vertical straight curve, swept them and trimmed both objects to the temporary plane.

I might be missing something, but I can split and trim the OP’s example without problems:

(exploded to show components left)

Rhino 6.14.19085.9141, 26/03/2019


I’m still in Rhino V 5. I’m probably too old to wait for recent releases to truly stabilize, and am also in the throws of building a new CAD workstation with the latest AMD threadripper CPU. So V 6 will have to wait. I’ve experienced the same problem in the past. It makes no sense to me that almost any other intersecting surfaces that apparently intersect will do so , but not these

How did you draw those profile curves? I can’t reproduce the minimalist surfaces you got (but my noisier versions split in Rhino 5)

That said, whacking a diagonal line across the joint in the top view and trimming seems quicker and cleaner anyway.