Inconsistent text height behaviour for Leader components

Hi,

Been testing the drafting components included in Rhino 8 and encountered seemingly odd behaviour when formatting text height of leader component using Annotation Text Setting. When the text height is changed from 0.9 to 1.0, the size of the text increases a lot more than expected. Futhermore, the size actually decreases when chaning size from 1.0 to 1.1. Bug or some misunderstanding of the usage of these components?

Kind regards,
Felix

Update: behaviour seems to be reflected for arrow size as well:

This is with Version 8 SR6 (8.6.24101.5001, 2024-04-10).

Thanks for reporting Felix,

This is similar to another youtrack RH-81800

Hi,

Yes, that seems to be the case. Did notice the original post in that thread but not your response. Good to hear that you’re on the case.

1 Like

I don’t see this same behavior here (see below). I tried to replicate your definition from your screenshots, so perhaps there’s something else going on in your definition. Can you upload a sample definition that shows this error so I can look at it on my end? I did just fix a couple of annoying bugs in the Leader component which will go into the next 8.8 release… but I don’t think those had anything to do with what you’re seeing here. FYI, I’m currently using Rhino 8.7.24121.13001.

InconsistentLeaderSizes.gh (15.7 KB)

Hi,

Difference in build seems to be the reason. The code you’ve attached shows up like this on my end:
image

Code attached to this post gives the following result on my end:

image

In that example I’ve only set text height, font and leader arrow size.

LeaderError-8.6.24101.5001, 2024-05-06.gh (7.8 KB)

Ok. Try updating your Rhino build and see if this fixes this issue. Thanks.

Problem seems to be persistent even in the .13001 build (same code as the one attached in the post above):

(8.7.24121.13001, 2024-04-30)

I’m also on Version 8 SR7 (8.7.24121.13001, 2024-04-30) but I see this:

and this:

[edit] I noticed your arrows were different and somehow recalled those from dimensions in inches: as soon as I changed default dimension style in Rhino to Inches Fractional, this appears

Yes. I think this could be because of whatever Rhino file you have open when running your Grasshopper definition. If you don’t assign any specific annotation style to your annotations, then it will use whatever the current annotation style in Rhino for all of the style settings that you aren’t manually overriding. Can you attach both your Rhino file and Grasshopper definition so I can take a closer look?

I don’t have any customization, I use the very same defaults Rhino offers

I can reproduce the problem in Version 8 SR7 (8.7.24121.13001, 2024-04-30) with these steps:

  • launch Rhino
  • in the window that appears at start I chose the default “Small Objects - Inches, Feet & Inches.3dm” (which is at this location “C:\Users\innoi\AppData\Roaming\McNeel\Rhinoceros\8.0\Localization\en-US\Template Files\Small Objects - Inches, Feet & Inches.3dm” )


Small Objects - Feet, Feet & Inches.3dm (28.8 KB)

  • launch GH
  • open your GH file


InconsistentLeaderSizes.gh (15.7 KB)

open Felix’s file:


LeaderError-8.6.24101.5001, 2024-05-06.gh (7.8 KB)

the issue is not generally items to be overscaled, it’s the “1.0” being somehow scaled differently

the annotation styles are the default ones from the Template file:

interestingly, the “Engrave” default style included in that template does not show the issue, while the other four styles do

[edit] I tried on several different Rhino template files, and the problem is present in all of them
also, for some templates -for instance Small Objects Centimeters- loading Felix file returns these error on Rhino command line:

An error occured in the display pipeline @ 14:16:56(880ms)
Message: Could not find DimensionStyle with ID 7f6f1c3a-f6a7-4c30-ae0e-44b5631d9c65
Type: DocumentCollectedException

Right. Which is why I need to see what annotation style are stored in your Rhino document. Could you please save and upload that file here?

I see the problem while opening each and all of these, which I believe come with Rhino installation:

Large Objects - Centimeters.3dm (27.4 KB)
Large Objects - Feet, Feet & Inches.3dm (28.8 KB)
Large Objects - Feet.3dm (28.8 KB)
Large Objects - Inches, Feet & Inches.3dm (28.8 KB)
Large Objects - Inches.3dm (28.8 KB)

here are the first 5 (max allowed uploads is 5 per post…) let me know if also want the remaining 9

I also edited the above post to show a display error in rhino command line

1 Like

Thanks. This is helpful. I have created a YT for this issue.

This should be fixed in the next service release build. Thanks for reporting this and your patience.

1 Like

RH-81865 is fixed in Rhino 8 Service Release 8 Release Candidate

1 Like

and…RH-81865 is fixed in Rhino 8 Service Release 8 :white_check_mark: for those not on the Release Candidate stream.

1 Like