I'm unable to shell a solid or offset a surface

Hi,
I’m a newbie with Rhino and just learning to use Rhino with Orca3D. I have created this hull shape using Orca. I want to shell this hull (add thickness to walls and remove the top (deck)). I have tried joinining the surfaces and running the Shell command, as well as deleting the top and rear (transom) surfaces and running the OffsetSrf command. Both times I get error messages in the console.

Failed to shell one polysurface.
Failed to offset 1 surface.

I believe I’m having trouble from the hull surface itself (the curved one) as opposed to the top (deck) or the rear (transom) surfaces as they are flat.
I undid the join command before uploading the file since I’m not sure if one can access the surfaces one by one after joining.
What might be wrong with the surfaces that might prevent shelling it? I’m trying to achieve a wall thickness of 50mm although I have tried other (bigger and smaller) values.
barge_wont_shell.3dm (368.1 KB)

Best regards
Teet

Hi Teet - the surfaces have neighboring edges that are tangent - as here:

image

You can see the U direction isocurves bend 90 degrees and become parallel to the V isocurves - this is allowed, but because the U and V are parallel at the marked location, the surface normal cannot be found and offsetting - which depends upon finding the surface normal - will be messy or fail. Generally this surface arrangement is not a good idea in Rhino. It is not uncommon for ship hull programs to do this however…

-Pascal

The result I have here is a combination of manipulating the inputs to Orca and afterwards playing with the surface to get it somewhat close to what I need. As usual force is not the way to work with CAD, it’ll bite you sooner or later… I guess it’s time for me to construct the hull manually since from scratch Orca doesn’t like to assist with simple barge shapes.
Thanks for the analytical answer though and best of luck to You.