Identify / show geometry from list

selecthighlight
unhandled
preview

(JunT) #1

Hello,

I am new to GH. I created a set of lines from points on two curves. I used “divide curve” and “curve closest point” to create perpendicular lines from curve to curve. I displayed the lenghts using “Line dimension” finally I used “Bounds” to get the highest value out of those dimensions.

My question is How can I preview/ highlight / select / display one specific line in my rhino viewport? . In my case this is the highest value dimension.
I’m sure this is something very simple for someone experienced. Longest Dimension 03.gh (8.1 KB)

Any help is greatly appreciated.


(Adam Mounsey) #2

Sort the lines by length and find the last item in the list. For this I used the “Reverse” option when you right click the list input. See attached.

You didnt internalise the data, so I had to create new curves.

Longest Dimension 03_Rev2.gh (9.8 KB)


(JunT) #3

Thank you! this worked for what I needed it to do. I appreciate the quick reply. Your definition is great.

Side note- Using the definition I sent to you I don’t know why my list item wouldnt highlight my line when selected. also, when using “bounds” the value for the highest value changes slightly from 3307.48 to 3307.60 when I reverse it.

Sorry I’m pretty new so I don’t know how to internalize the data. I will do it for next time.


(Adam Mounsey) #4

You can internalise the date by right clicking on the curve component and selecting “Intenalise data”.

It’s strange, I tested in both Rhino 5 and R6, with the latest GH build, and both show the correct values for me.

For the preview (I’m guessing this is what you mean by highlight), either disable the preview for everything but the list item component, or click the “Only draw preview geometry for selected objects” option (one of the top right icons) and select the list item component.


(JunT) #5

Thank you!

Btw sorry I found that there is a flaw with my starting definition. it gives parallel line only on one side but not both. This didn’t happen before with other sets of lines but I tried a new set and it did.
I highlighted the lines that shouldnt be there.
How could you prevent it from giving you those extra non parallel lines?
Again I appreciate the help


(JunT) #6

Longest Dimension 03_Rev2 IntData.gh (14.0 KB)

forgot to upload definition
This time I internalized data. I hope it worked


(Matt Gaydon) #7

Try this… It removes the duplicate closest points, then uses shortlist set to trim start to remove the excess points from the other list before creating the lines.

Longest Dimension 03_Rev2 IntData_MG EDIT.gh (23.0 KB)


(JunT) #8

Amazing! this does the trick. thank you!

However for some reason the line doesn’t highlight on my rhino viewport anymore when I select “sort item”


(JunT) #9

nvm I had to hide some things to make it show.

thank you again!