I saved a user object, but when I use it later, my input and output names disappear

The object I made is on the left. The object that appears when I drag it from my user objects menu is on the left:

This is what my outputs look like inside the cluster:

I’ve tried renaming the outputs, tried removing them from groups, tried every variable I can think to try, and nothing works.

Also, when I save a user object to a menu, I have to save, close and reopen rhino before the object appears in the menu.

Is this all normal? Am I missing an update? Am I doing something wrong, please advise.

For sure this is not normal. But you have to provide a gh file in order for anyone to help you.

Have you tried setting the output nicknames from outside the cluster (right click where it says Line and rename to X etc.), then make the user object? I usually do that and it stays, unless this is a newer bug you are experiencing.

Also, are you in Mac or Windows? What version and service release?

I figured it out. I had clustered my cluster. Once I undid that, it worked fine.