I am getting dashed lines when they should be normal

drew a circle and it went dashed, checked the layer and it was CONTINUOUS.
transferred circle to DEFAULT layer but still dashed.
shut down rhino, relaunch and draw a new circle and dashed.

I am unable to draw circles as continuous type.

This is in the same big project file that got distortion and scaling happen to objects after I ran a macro today.

What to do as I need continuous linetype ?

I selected all layers and chose delete leaving just the default layer and its now continuous.

I had this problem many years ago. Has my file reached its limit as its very busy now, .


Does this happen in a new file? Does this happen only with circles?
Is your graphics card driver up to date?

I have been doing testing to establish the cause and the results are most odd, Its good for McNeel to see the full results,
Dashes are short and long, not like a chosen dashed line.

Doesnt happen in a new file,
doesnt happen if I delete out all the layers except the default I then placed it on,
doesnt happen initially with any file and project.
Does happen when the project has grown and grown, hundreds of layers, many linked images pictureFrame.
I recall this occurring some years ago when I had another complex project, its as if Rhino has a mental processing limit then starts acting up.
Its ok as long as things are not featuring lots of objects, layers and images. As to which of those is the trigger point I dont know.

I have opened my project file, selected another layer,
Lets do the tests., important for McNeel to see the trigger point as well as myself.

I try all the circle and arc tools, they all have dashed lines, draw a smaller circle and it doesnt even show because its made of the gap in the dash.
Draw a curve with the curve interpolate points and its ok, likewise the control point curve.
Next I use the conic but dont understand the tool so dont finish the move.
I was about to delete the image layers to see if that was the cause, I now can draw again.
I undo all stages back to file open, draw a circle and its solid.

I save this v8 file as v9 keeping V8 ‘polluted’.

I open v8 (saved with dashed circles last night) and dashed circles are still there.
I draw one, dashed, arcs and circles still afflicted, try a conic, thats solid. try curve tools, solid.

I delete all the RASTER layers with my linked images except for a second set with 5 in. Doesnt fix it.
Draw a helix and THE DASHES GO SOLID ON ALL.
edit undo multiple back to when file opened, still able to draw solid now., so images dont seem to be the problem.

close file without saving so I can test for other factors. I have v9 to carry on with.

Open V8 again, dashed issue is there, this time delete the secondary folder that has 8 images in it, and the DASHES GO SOLID.
reopen v8 and work my way through that folder, deleting each one, no change, delete very last one and DASHES GO SOLID.
may have found the cause !

I reopen without saving and experiment, image is visible in TOP view. The image has got curves grouped to it, elipses and lines.
My dashed circles are in RIGHT view.
unlock the image layer, no change, move it ortho upward no change, move it right, DASHES GO SOLID. undo that move, dashes are back. move it left dashes and the circles both vanish completely ! undo that move.
Draw a circle in TOP view and that appears solid but those in RIGHT view vanish completely ! undo that.
Draw a circle in BACK view and that appears SOLID and also the dashes go SOLID !

reopen v8 and draw circle in TOP view and dashes and circles both vanish in RIGHT view.
undo and draw circle in BACK view and get solid and also dashed ones go SOLID.

Test for grouping of drawn items to image:-
reopen file, ungroup elipses and lines etc on image, draw a circle in RIGHT view and its dashed. So grouping not the cause.

reopen v8, first thing i do is draw a line in BACK view and dashes go solid !
undo and they are dashed again, draw a line in TOP view and in RIGHT view they vanish along with the circles !
NOW GET THIS !! …I Draw a circle in RIGHT view AND NOTHING APPEARS AT ALL, draw lines, nothing appears, unable to draw curves in RIGHT view ! try for a cube tool and it appears and the circles are back as solid lines !

This image is rotated, thats often done, others are scaled 1D, also 2D, done this for many years. All are jpg, all are inserted pasting in their width taken from properties in Photoshop same units etc.
Nothing different on this one, all are B/W. Been doing this since day 1.

What other tests would McNeel like me to try on it please ?

As for the GTX970 I am sure it isnt at fault, I have never any reason to grumble with it. One thing though I get slashes through verticals in video playback on panning shots, lamposts, window frames all see cuts and offsets which come together when pan stops. Eizo £1400 video monitor ?, card ? playback prog ?
Eizo say not them. Flight sim flies all setting at max, and its an intensive one with many aircraft (CoD)

I look on Nvidia website , the GTX series is not listed, I go to MSI, select manual driver update, takes me to that Nvidia site again !
OS list doesnt even mention win8 , only win10. maybe it might if I could find GTX970. The GTX970 is 4 yrs old as a card, superceded by the GTX980 a year or so later, No GTX cards are listed !
I am with driver 17/7/2019 so just about 2 yrs old and clearly I had updated the driver since first install in Oct 2016.


I’m sure they’re REALLY concerned about a glitch on an obsolete version of Rhino on an obsolete version of Windows on 2014-vintage hardware…yeah. Anyway, back in the mists of time I recall an old bug where the “camera” in the parallel views would somehow with use get moved to some bizarrely short or was it long distance away, causing various odd effects, and resetting the viewports with 4View fixed it.