How to use HDR environment files in Rhino 6

I used to be able to use HDR files as environments in rhino 5, using the native rhino renderer (not V-ray). In rhino 6, in the environment panel, it will let me import the HDR file and will show it as a high dynamic range texture, but it won’t register as the environment, or show up on the rendering. When I try to assign the HDR file to the environment settings in render options, it won’t accept it, apparently not supported.

As mentioned, this was easy to do in rhino 5, how can I do in rhino 6? I have downloaded a whole lot of nice environments that I’d like to be using. Btw, this question has been posted twice already for V-ray, which I don’t have or know how to use, so I’m posting separately. Thx!

OP here, I believe I figured it out: in Render options I chose the 360 environment, then edit (little pencil emoji, had missed it) and assigned my HDR file as the new background image. It worked, my HDR file shows up as the environment. Now I’ll experiment with the options for type of projection (automatic, cubemap, light probe etc), and intensity levels. If there is a guide/manual that explains each of these please advise.

Indeed the way is the set your HDR image as the background image of an environment, then set the environment to 360°. Note that you also can set it as custom reflection or/and skylight environment.

Your HDR is probably equirectangular, so set projection to spherical.

Skylight has effect in Rendered viewmode, and Raytraced. And in Rhino Render of course.

@connie You can also drag and drop an HDRI into an open Rhino 6 viewport and choose to make an environment from it.
image

https://docs.mcneel.com/rhino/6/help/en-us/commands/environments.htm

1 Like

Hi,

I have a 360 degree panorama photograph, taken of the city around my site, as a jpeg not HDR, which I would like to map as my environment, much like the “out of the box” Rhino Sky.

From these posts and experimenting, I can see that Rhino does not like a jpeg as the image for a “high dynamic range texture”, but a “simple bitmap” does not work either.

I cannot reshoot the image as an HDR, since it was drone photography over a city which required a special license, so is there a suite of settings I should use to do this, or can I convert the jpeg to an HDR, please?

Thanks

If it is just a regular equirectangular image you should be able to use even JPEG as the environment:

  • Open Environments panel
  • Add a Basic Environment
  • Add your JPEG image as the background image
  • Set projection to Spherical

Now you have an environment created from your JPEG. You can even use it as lighting, just remember that you won’t have as good values as a HDR texture with large dynamic range (i.e. areas with high energy).

To combat that you could duplicate your newly created environment and for the one you will use as lighting you set a high intensity factor.

Thanks Nathan

I noticed that my 3D mouse also wasn’t working, so I repaired Rhino, rebooted and then … the Basic Environment worked. So there was a glitch somewhere.

I just need to sort out the ground image, which is currently white and then I will be “cooking on gas”.

Nick

In the Rendering panel you can edit the Ground Plane material, make sure it’s set to use material versus the default of shadows only. There is also a special scale for textures within ground plane materials since that is an infinite plane.