How to turn off oneview in the menu




how can I turn off oneview “forever”.
I accidently turn it on or I dont know. I turn it off and than it is back.


(Pascal Golay) #2

Hello - does Rhino start with OneView active, or does it kick in at some point later?



Hi @pascal,

it starts with oneview enabled.I disable it but it returns.


(Pascal Golay) #4

That command is not lurking in the startup commands in Options > General page, by chance?



Hi Pascal,

No it isnt.


(Pascal Golay) #6

Hmmm - and, do you have any scripts loading in Options > RhinoScript page? Or possibly an alias that is close enough to ‘OneView’ that typing it quickly gets you the wrong thing?



No, not any script loaded, no keyboardshortcut, it seems to occur when toggeling the views.

(Pascal Golay) #8

Hello - how are you toggling the views, exactly? What action or command?




ctrl+F1, etc

(Pascal Golay) #10

Can you verify in Options > Keyboard page that the macros for Ctrl-F1 etc are like this:

’_SetMaximizedViewport Top





(Pascal Golay) #12

I’m at a loss… Is this predictable, repeatable? If so, please make it happen, then look at the command history (F2 key) and copy/paste the last few lines here. I can’t help but think the solution is probably dead simple, but right now I do not see it…



sorry for that, I also imagine some simple error (commited by me).
Ill try to observe and post the history.
Thanks for your efforts!



I have the opposite problem - every time I reload Rhino, the OneView is turned off.

(Pascal Golay) #15

Hm… one other thing - make sure the Rhino session is the only one open, disable OneView and then re-open… Any better?



Ill try it thanks again!


I just tried its still happening.

(Pascal Golay) #18

Very strange. The command is in the Commands plug-in - can you check Options > Plug-ins for this plug-in and right-click and get Properties and send a screen shot of that page?