How to get correct results with the new FlowAlongSrf

The new FlowAlongSrf place the flowed object in a wrong location on the target Srf.
I have tried the various options in the command and read the Help but I can’t get it to work correctly. The simplest thing, just flowing a curve from a plane on to a cylinder]

thanks a lot

it is indeed off. I found that using Dir → V Reverse corrected the flow, but this definitely seems to be a bug

I’m not seeing that on a slightly newer build. Could you post a simple file so that I can make sure we are looking at the same thing?

Thanks Wim
here is a file with the issue the orange curves were made in V5.5 and are correct, the red curve was made in V6wip and it flows into a wrong location.
It seems that for a new file in V6Wip the flow works correctly. Editing V5.5 files bring about the location error .

FlowAlongSrf.3dm (12.2 MB)

Hello - it does depend on the pick location - if AutoAdjust is on, picking near corners of each surface should affect the outcome, if AutoAdjust is not on, then the mapping is straight U, V, Normal to U,V, Normal and pick location does not matter. (most predictable, imho)


Thanks Pascal
it did tried the different settings before writing the initial post.
but none works correctly it gets the U,V, Normal upside down [I guess]
*just checked again with the new build.

Hello - here’s a clip, recorded on Windows because I have a better screen grabber but it is the same on Mac here, I just made sure:

Can you replicate that?


it doesn’t work here with or without auto adjust .
[again if I make a new file in the wip that works fine, but not the files that were made in V5.5

thanks for looking into it


I see … but the file you sent appears to be a V6 file and that does not work, is that correct?


yes it does not work correctly here, this happens with files that starts as V5.5 and then worked on in V6 [whether they are then saved as V6 or V5 seems to makes no difference for this issue]

thanks a lot

I have tried this by first making a new file in 5.5 and then opening that file in the WIP. I was not able to reproduce a problem. Could you post a file that is saved in the 5.5 format?

here is the same original file in V5.5
[the parts I can’t share were removed]

and it is the same issue with other files here,

v5.5 flowAlong Srf .3dm (4.7 MB)