How to export WAMIT higher order gdf file (from surfaces not mesh)

Hi,

I can see that when I export a geometry mesh to a WAMIT gdf file, a gdf file for lower order calculations is created (ILOWHI = 1, IGDEF=0 in WAMIT). This file works great in WAMIT, but due to the slow nature of lower order WAMIT calculations for large multibody analysis, I would like to run higher order calculations. I can see that when I export the geometry surfaces (instead of mesh) from Rhino to a WAMIT gdf file, Rhino automatically creates a WAMIT file that looks like a higher order file (containing patches not panels for IGDEF = 1). Unfortunately, WAMIT is not able to run the file. I have tried with a very simple geometry (a cylinder) but cannot get a working gdf file containing patches (IGDEF = 1). How can it be done?

Thanks,

Sarah

From what I remember, WAMIT does not allow any trimming information with respect to surfaces in the high order gdf file. No one at McNeel is even close to being an expert at WAMIT, so it may be best to bring this question up with the WAMIT developers.

I wrote the file exporter for Rhino and was working with a user at the time who would tell me if what was being exported was correct or not.

Hi Sarah - my wild guess of the moment is that WAMIT does not like either rational surfaces (cylinder) or trimmed surfaces (caps on the cylinder) or both. Try a box…

-Pascal

Hi,

Thanks so much for the reply. Can you remember when you were developing the export function, what type of surfaces did work when exported to wamit? I will go back and check that I have no trimmed surfaces.

It’s a real shame there is no error function, as everything looks great until wamit just doesn’t run, so I have just been using trial and error.

Many thanks,

Sarah

Sendt fra min iPhone

Den 8. jun. 2016 kl. 17.39 skrev Steve Baer <steve@mcneel.commailto:steve@mcneel.com>:

[https://sea1.discourse-cdn.com/mcneel/user_avatar/discourse.mcneel.com/stevebaer/45/9463_1.png] stevebaerhttp://discourse.mcneel.com/users/stevebaer McNeel
June 8

From what I remember, WAMIT does not allow any trimming information with respect to surfaces in the high order gdf file. No one at McNeel is even close to being an expert at WAMIT, so it may be best to bring this question up with the WAMIT developers.

I wrote the file exporter for Rhino and was working with a user at the time who would tell me if what was being exported was correct or not.

Visit Topichttp://discourse.mcneel.com/t/how-to-export-wamit-higher-order-gdf-file-from-surfaces-not-mesh/33244/2 or reply to this email to respond

To stop receiving notifications for this particular topic, click herehttp://discourse.mcneel.com/t/how-to-export-wamit-higher-order-gdf-file-from-surfaces-not-mesh/33244/unsubscribe. To unsubscribe from these emails, change your user preferenceshttp://discourse.mcneel.com/my/preferences

I think Pascal may be correct in that rational surfaces are not supported.

Thanks both Pascal and Steve!!! I have succeeded with a cube by avoiding trimmed and rational surfaces. So, the next step … how could I draw a cylinder whilst avoiding trimmed and rational surfaces? By the way, my actual drawing is way more complex than a cylinder and requires a combination of curved surfaces and straight lines…but a cylinder is a good starting point.

Many thanks,

Sarah

Hi Sarah - make a Polyline that is half of the cylinder. Use Revolve to create the cylinder, using the ‘Deformable’ option. The result, depending on the deformable options, will be very close to but not exactly a true circle. ‘Deformable’ makes it non-rational, but also non-exact…

-Pascal