How to enable AR in iRhino

How do I enable the AR mode? I can’t find a button for it!

(In fact, I can’t see buttons for section views either, which apparently should be in the app somewhere?)

Tap the button in the top left and change the display mode from “Shaded” to “Rendered - AR”

1 Like

Oh, that’s an odd place for that feature. So what happens if I’m in Top view and enable AR shading? Is it still locked to the top view regardless of how I move the camera?

Also, I tried it now and the scale was completely wrong and the model ended up floating about a half meter above the table I was pointing at.

Finally, the framerate using Rendered - AR was about 1-2 fps, which definitely could be improved, because the iPad Pro I have is apparently quite powerful.

If you’re using the latest version on Appstore (iRhino3D v8.0.23058) you should be able to choose between a few modes of anchoring your model in AR.
The default mode is not tracking a table, it puts the model at a point mid air about .5 meters away from your camera.
You can switch the AR mode to “Horizontal Surface” or “Vertical Surface” to anchor the model to a surface. You’d have the opportunity to lock the model’s position to a point on the surface

Re:Scale, we’re not doing anything to determine the relative size of the model in space right now. But that’ll be a good feature for us to add.

That is terribly low but of course it could depend on the model and device you’re using, I get very fast frame rate with the models I’ve tried. If you can share the model you’re having issues with, I’d be happy to take a look.

1 Like

Hi @mkarimi
Was trying the Vertical surface mode, and it may work well if the iPad was on a tripod… but hand held here, the model keeps getting spasms trying to lock into surfaces… [ iPad Pro M2].

would this possibly have something to do with the model being small [a piece of jewellery] and the distance setting being in meters …?

perhaps if we had a way to set the distance manually, or perhaps if it could take the model units in consideration ? It just sound to me as if there’s a meter unit super imposed on a small millimeter model.

thanks a lot
Akash

@Akash you need to tap the “Lock Position” button to anchor the model to a point on the surface.

It should work the same regardless of the model dimensions. You can adjust the scale by pinching in or out.

Hi @mkarimi thank you.
The lock works for stabilizing the model, thanks for the explanation.

I guess my main wish with the AR mode, is to have control over the camera.
The current setting it would seems, is tuned for architecture models, while for me [working in jewellery] the AR mode would be a great way to have customers virtually ware the jewellery!
Allowing them the virtual experience equivalent to coming to the studio and trying on the physical jewellery!

For this we’d need a way to put the jewellery on a surface [be it the body of the customer, or even just the let is rest on the table.
At the moment [as far as I was able to test the mode] the model is always floating in space. it is not resting on anything…
Do you think this is achievable ?

thanks a lot
Akash

Yes please! :coffee:

You should be able to anchor the model on a table using “Horizontal Surface” AR mode.
I have to research a bit to see if what you’re suggesting for anchoring the model to customer’s body is even possible and if so, what the accuracy is like.

I logged your feature request here: https://mcneel.myjetbrains.com/youtrack/issue/RV-769

1 Like