How to eliminate frame around pictureframe image in paperspace?

I’ve searched for the solution but I can’t find it. Help please. I just want to be able to insert an image into paperspace without having the lined border around it. Thank you.

1 Like

I just change the shade mode on the layout page to “shaded”, and the edges disappear

Thank you James, but that does not work on my end. Changing to shaded mode keeps the border line, but it does manage to hide all my other lines in paperspace.

Hi Peter - set the objects’ display mode (SetObjectDisplayMode) to a mode for which surface edges are turned off.


Thanks Pascal, but that also did not work. I’m attaching the file itself for review. Attached.border-around-image-in-paperspace.3dm (1020.5 KB)

1 Like

Hmmm- should work - erk… you’re right, it does not work if the viewport mode switches away from rendered. Thinking…

Dumb workaround: make the object color the same as the page color.


Tried it but still nothing. Maybe I’m not changing the right object properties? Where exactly are you changing this color?

Hi Peter - in Object Properties:

Any luck?


Thank you but still no luck. Did you have luck? What color did you change it to?

Hi Peter I set to a light gray that matches the page color in the layout. (default - rgb 192,192,192) Does the attached look OK? Maybe I am trying to solve the wrong problem.

border-around-image-in-paperspace.3dm (254.6 KB)


I was really hoping your file solved it, but it’s still showing for me when I print. :cry:

Ah, OK- set Print color to white.


I did that and still same…

Are you able to reproduce a print (even just the print preview) so the border is no longer showing?

Hi Peter - yes.

Print color set to White, Display color black (edges show in the layout itself)


Ah, but you have your background color set to grey? So when you print your sheet on a printer, does it print the grey or does the grey just come out white?

Still doesnt work. :frowning: My print preview is still showing a border around the image.

1 Like

Hm - here’s my result-

border-around-image-in-paperspace.pdf (212.9 KB)

‘Output Color’ in the Print dialog set to ‘Print Color’, btw…


Ok, that solved it. Setting the “output color” to “print color” was the key. Thank you Pascal! But Im curious. Sometimes my client doesnt want the image to have color… how would you set the image the b&w? Would I have to manually desaturate it prior to attaching the pictureframe?

I have not actually done this, but it seems like the way to go if you want other colors in the print - if you want the whole thing as grayscale, use the ‘Black and White’ output setting. Is that what you mean?