How to change clipping plane shaft length

My clipping plane has a really long shaft length? Where is the option to shorten it? Thanks

Hi -

There is no such option.
The current state is the result of you scaling the clipping plane. You could scale it back to the original size or create a new clipping plane that has the intended size from the start.
-wim

oh ok. I’ll consider it as a feature wish then

Hi -

In that case, you might want to describe what problem this would fix.
-wim

In my case, I have a lot of clipping planes in my architecture models and all the lines are really long and cut across the viewport at every angle. It’s visually confusing. I feel like its one of those cases where people would not guess the solution easily. Because I was tweaking everywhere in options and viewport options, and turning on the control point seemed to do something but not really working. I did spend a ton of time trying to figure it out but there are just no such options as mentioned :frowning:
Is there a sub-menu option somewhere to scale it back to the original size? Maybe an option can save other users some times to figure out the same problem next time

1 Like

I have the same problem but I use this macro to replace ClippingPlane and matchproperties. It is not a one click solution but it is a bit faster…

_-ClippingPlane 3Point _Pause _Pause _Pause
_SelNone _Sellast
_-MatchProperties

/Fredrik

Note that clipping planes in Rhino 8 no longer have such line…
image

-wim

1 Like

Agreed. This would be nice. Everything else in Rhino at least has control points or similar. Not sure why clipping planes don’t.

Run Pon (PointsOn) on a clipping plane…

True for 8. I’m sticking with Rhino 7 until a few 8 bugs are squashed, most importantly the layer dialog lag, the worst of the bunch and a trust killer.