How could I render proxy models (.e.g enscape) in Arctic mode

this is the result from arctic mode in rhino and it looks like ciarse mesh so how can I make it looks like render smooth mesh in Rhino acrtic mode

@nathanletwory any help :pleading_face:

Looks to me like these models are coarse to begin with. If you need better quality models you should try find out if for these models you can get better settings.

You probably will have to ask Enscape if these are from them.