How can i planarsrf between 2 concentric curves

(include but not limited to circle)

especially for curves that have many control points, trim or split, even sweep 2d will distort the shape to an unacceptable extent. i.e, the plane won’t fit into the curves.

For instance, this is an instance I’m working on.

Does anyone have ideas
planarsrf_concentric_problem.3dm (2.9 MB)

This is created in grasshopper, so any methods work in grasshopper is also welcomed

Hi Wei -

Simply running PlanarSrf on these curves will create a correct surface.
What you are seeing is the display mesh that tries to visualize that surface.
You can modify the settings on the Document Properties -> Mesh page. If Smooth and slower is to coarse for you, you can go into the custom settings. If you have lots of objects in your scene, this can quickly lead to a large file and slow response in the viewport. If that is the case, you could consider modifying the mesh settings for that object only. You can do that in the Properties panel with the object selected.

1 Like

Tks. I also find that (now). It’s truly a bit weird. I duplicate from another file, in which it didn’t work.

I didn’t notice it work after i put it into a blank one.

Here’s how it works in the original file. It create two surface instead of one. And i’m pretty sure the curves are precisely the same.

If you don’t mind, could you explain a little it about what makes the difference

Hi -

You’d have to post the file in which this is not working. I suppose it could have something to do with document tolerances.

weird behavior.3dm (15.7 MB)
Here it is

Hello- the distance between the curves is about the same as the file tolerance - which means the tolerance (.01M, is that really what you want?) is too large. Try .001.


1 Like

Love it, straightforward yet very helpful answer. It well explains why it works in an inch unit file.