How can i import points from excel to rhino?

how can i import points from excel to rhino?

maybe you can start there

Python is not needed.

Create a sheet in Excel which only has the x, y and z (if needed) coordinates of each point. Start in the first row and first column. One coordinate per column and one point per row. No gaps. No headers or other text information. Make sure the columns are in Number format.

Save the sheet as a Comma separated values .csv file.

Use Import command to import the .csv file into Rhino.


thank you

What am I doing wrong?
Nothing happens when importing…





Thanks :slight_smile:

Can you post the .csv here?

Hi Helvetoraur!
Thank You for your fast reply :slight_smile: Awesome :slight_smile:

points import rhino.csv (15 Bytes)

I have changed (column,row) the class from common to number. After saving .csv and opening in excel, it shows that these are common again.
Sorry, don’t know exact words, because my excel is not in english.

No problem here.
I dragged and dropped the file with points, select “import file” seen on your picture, on another screen select the separator (semicolon) and I see 3 points.

It did not open any window for me to choose. Only error message to the command line.
I changed “,” to “.” in windows setting and now it works.

Thank You :slight_smile:

No, it was something else. Error again. I think problem is in excel…
It works when using exact numbers(fe. 5), it does not work when using “,” or “.” (fe 5,0 or 5.0)

Edit: I restarted my computer. Now it imports but only integer.


I changed 2,2 to 2.2 in excel… Error in importing…

Ok, now it works very weird…

File number 5 imported but only whole numbers. I deleted file 5 dots from Rhino.
File number 6 did not import, only error.

I wanted to test file 5 again and now it did not work… :open_mouth:
Then I tried file 6 again and now it works correct…

I did not do any changes to the .csv files…

Very weird.

This looks like a problem with comma/period decimals. Rhino only accepts periods as decimals, so your entries in the .csv file should look like 5.5 and not 5,5. You may need to run a global search and replace for commas to periods in your .csv file.

Ok, I maybe got it.
Now all files works, if it is not open in excel at the same time.
When I open file in excel Opendrive makes it syncronizing in folder.
If it is open in excel it gives error in import.

If I close excel file, then it does not syncronize anymore after few seconds.
Opening file after that it imports normally…

EDIT: It works like that also when file is on desktop. So excel file can not be open at the same time.

Yeah, dunno, Excel is always weird with that - I generally save as a .csv and then close the file in Excel and open the .csv in some text editor and do the find/replace.

Yes very weird, but great it works now.
Just a little bit annoying if you want to check excel and Rhino at the same time and change numbers. Then you have to close and open and close and open… instead of just saving…

But anyway it works now :slight_smile:

Thank You, glad to be Rhino client, thinking to upgrade to R7…

I recommend to use csvedit for manipulation with csv data. It is great tool.

1 Like