Hops not working. Unable to start a local compute server

Hi there,

I’m getting this error when trying to use Hops component, even when I’m just pointing to the built-in component.

“Path appears valid, but to something that is not Hops related . . .”

Here is the snapshot from thino.compute window:
rhino.compute window snapshot.txt (5.4 KB)

It says “System.Exception: Unable to start a local compute server” a couple of times, but I have not idea how to resolve it.

It would be greatly appreciated if someone could have a look and propose a possible solution to this.

Rhino Version 7 SR11
(7.11.21293.9001, 2021-10-20)

Hops v0.12.0

Hi Valentin -

The current version of Rhino 7 is SR16. Please update your installation.
-wim

Hi Wim,

Just updated it to SR16, same Error is returned by rhino.compute window.

rhino.compute window snapshot_SR16.txt (5.3 KB)

Hi Valentin. Are you using a local instance of rhino.compute to handle your Hops requests? Or are you pointing to a remote server? When you go to File>Preferences and then click on the Solver section, you should see some Hops settings on the right. Is there anything in the Hops Server URL or API Key sections?

Hy Andy,

Those fields are blank:
image

This is what is rhino.compute window shows upon launching:

Ok. Thanks. Those screenshots are helpful. Let’s try another thing. Can you opening a File Explorer window and going to C:\Users\yourname\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\Hops\0.12.0. Inside there you should see two sub folders, one of which is called compute.geometry. Go into that folder and launch the compute.geometry.exe application. If it loads correctly, you should see a message that says “Listening on [“http://localhost:8081”]”. If you see that, go back into Rhino and Grasshopper and type http://localhost:8081 into the textbox at the top of the preferences window where it says Hops-Compute server URL. Now, try adding a Hops component onto your canvas and specifying a path to a Grasshopper file. I’ve attached a very simple “Hello World” example that I often use just to debug things because I know this file should work just fine out of the box.
HelloWorld.gh (4.8 KB)

1 Like

Thanks so much @AndyPayne !

It resolves the issue. The only thing is that it only works if I launch compute.geometry.exe first, then (making sure Compute Server url is provided correctly into Grasshopper Preferences) the hops component works in Grasshopper.

In other words, it is not launching compute.geometry.exe automatically when hops component is placed on the canvas and the path is specified.

Great. I’m glad it’s working. This is only a temporary solution until we can figure out why the server is not launching properly and release a patch.

1 Like

Hey @AndyPayne

I get this issue when I fire up a hops component

When I tried the above solution, it compiled the component parameters, but then failed to execute the component and generate an output

Any suggestions?

Hi everyone. I think we now know what the issue is and will be issuing a new release which will hopefully fix this issue moving forward. However, we think the issue has to do with COFF loading. To fix everything, type GrasshopperDeveloperSettings in the Rhino command prompt before you launch Grasshopper. Make sure the checkbox is set to unchecked for the option to memory load .gha assemblies using COFF byte arrays. Then try to launch Grasshopper as you normally would. Hopefully, this will now launch the rhino.compute instance as it normally would. This is only a temporary fix as the next release should work whether or not this COFF setting is set. Anyway, I hope this helps.

Hi Andy,

i did all of configurations what you suggested before comment. But, I got this error message:


I think the problem is that the local computing settings didn’t installed in my computer. Then, I tried to follow the steps in “Running and Debugging Compute Locally with C#, VB”. It didn’t also work :smiley: .
grafik
I got this error. The error message said that the folder didn’t find. Actually, I cloned this from github. I didn’t use visual studio before. Maybe the solution is super easy. But, I will be pleasured all of your help

Hi @Mertcan_Kaya Did you install Hops via the package manager? And then try to build from the github source repo? You probably don’t need to do that (unless you’re really trying to debug something difficult). You should be able to type PackageManager into the Rhino command line and install Hops through that interface. I would recommend installing 0.12.0. You will need to restart rhino/grasshopper for the changes to take effect… but before you do, type GrasshopperDeveloperSettings into the rhino command line and make sure the COFF checkbox is unchecked. Now, restart rhino/grasshopper. This time, go into the Grasshopper Preferences and click on Solver (bottom left) and then you should see some Hops settings in the top right. Uncheck the checkbox that says “Hide Rhino.Compute Console Window”. Restart rhino/grasshopper one more time. This time when you start Grasshopper you should see another application show up in your taskbar. This is the rhino.compute server which will listen to requests sent from Hops. Try adding a Hops component onto the canvas and right-click to set the path to a Grasshopper file. I’ve attached a super simple “Hello World” example which should definitely work if everything is working correctly. Can you try these steps and let me know if you run into any problems?
HelloWorld.gh (4.8 KB)

Hi Andy, I did same, what you said (I could’t build from github, as I said in my previous comment). I also changed the GrasshopperDeveloperSettings and “Hide Rhino.Compute Console Window.” Then I restart rhino. But, I didn’t see this another application. Furthermore, I got this error message in rhino.compute:

I also have the same issue - my COFF check box has always been turned off and I am receiving the error.

@Mertcan_Kaya are you using Windows Server? If so, that’s a different setup. I believe you’ll need to license your Rhino using core-hour billing. Usually we recommend this type of setup for running rhino.compute on Windows Server: Deployment to Production Servers with C#, VB. I think this issue is separate from the issues mentioned above since it assumed you were running Rhino and compute on a standard Windows setup.

Thank you Andy. You’re right. I am using Windows Server in my work station. I tried also to use Hops in my laptop(standard Windows). It works. I will try your new suggestion for my work station. If it doesn’t work, I will get in touch.

@comp-designer.nz Were you able to get Hops working on your machine? If not, could you provide some more information about your setup?

I managed to get it to run using the solution above. However, when I reopen the script I have to re do everything which is a bit of a pain

@comp-designer.nz can you describe what steps you have to redo? If you have the COFF setting turned off, then you should have to manually start the rhino.compute instance and put the URL in the URL section. If you remove any URLS (in the top text box in the Hops Preferences) and then restart Grasshopper, then rhino.compute should start automatically every time you start Grasshopper. You can choose whether or not to show/hide the rhino.compute application using the checkbox in the Hops Preferences as well.

Yup, that fixed it right away, thanks for the debugging, isn’t that option checked on by default on all new installs ? Will you find a way around it ? Is that setting checked on beneficial for the general operation of grasshopper ?

No more questions