Hops Input/Output Bug


After months of watching the Hops development, I finally had some time to explore and try it out. However, I’m having unpredictable results. I created several Hops components that worked fine and was exited to have this new resource. However, I just created a new one that is almost identical to a previous one, and nothing is working.

  1. The inputs don’t accept wires. See screenshot. Instead of wires snapping to the inputs, they act like they aren’t there.
  2. There is an output in the reference file called “RH_OUT:StreetWidthSet” but the Hops component doesn’t show that output.
  3. One of the three input parameters from the Hops reference file are not loading in the main Hops component. There should be an input called “Street Width List”.

I’ve deleted the component, recreated it, cleared cache, forced recompute, etc. Nothing fixes it. Any ideas? Am I just making a simple newb error? Thanks.
Attached are the internalized Hops Main and Hops Ref files.
Hops_Main.gh (5.1 KB)
Hops_Ref.gh (15.8 KB)

Ah, maybe I figured it out. I removed the default values that preceded the Get Geometry, Get Number, and Get Integer and it all works now. Based on the tutorial video, I had assumed that you could input default values into the Get components but that these would be overwritten by any value that was being sent from an outside file to the reference file. I guess this isn’t true.

Ideally it would be true. This would allow default values to be set in the reference file. It also allows someone to open the reference file and see it working.