Hiding rectangular lights in render

I need to render a room viewing the whole room with the ceiling hidden, lit with light fixtures, which also need to be hidden. I have created the light fixtures by modeling them, and then adding rectangular lights (flamingo) to them. However, when I hide the fixtures and rectangular lights, or turn off the layer that contains them, the rectangular lights still render as black rectangles, obscuring the view I require. I cannot seem to get rid of them by any means.

How can I accomplish this?

Select the light an go to the light Properties. There you can un-check the Visible checkbox. The light will cast light, but will not be visible. This is for the idealized rectangular light. The standard Rhino 5 rectangular light.