Rectangular Light

Silly question: I created a rectangular light in my model. While the light is “on”, it appears completely transparent in the render while still casting light. My expectation is that the light source would be visible, no? I attempted to add an emissive material to it, but it still shows as transparent. Is there a special setting I’m missing here? Thanks.

rectangular lights will not show, if you want a surface that actually shows up you have to use a regular surface and use that emissive material. you can not add an emissive material to a rectangular light, if that is what you tried to do.

I appreciate that @encephalon. Am I misremembering that at one time rectangular lights were visible? I’m thinking as far back as version 4 or 5. Thanks again.

no, panel lights will reflect, but not be visible.

adding an emissive material to that surface will be the trick. Keep in mind the light shines in the direction of the surface normal. Check that with the dir command.

No. “Light objects” are fake simplified light sources that date back to the dawn of rendering. They don’t actually “exist” as objects in the model, they’re just points with lighting parameters. You always needed separate “lit up appearing” geometry to fake the light source being “visible.”

Modern path-tracing lets you just realistically model a proper light fixture and illuminate it with almost no performance hit.


there recently was a bug in the WIP version where lights suddenly showed, so i assume it would not be difficult for developers to make it possible. i can not recal lights ever showing before.

Hi, I am having an issue with the rectangular light option on Rhino 7. I was adjusting the lighting set up for a scene and suddenly my rectangular lights started to show as white rectangles. After having spent hours trying to figure out what was the problem, I finally found out that the problem occurs only when the light source goes through a glass surface as you can see in the images attached (I also tried to make a PBR glass material and the problem remained). Things were working properly initially as shown on the screenshots of the initial post. I look forward to hearing from you. Thank you

@Oualid_Kouah I don’t see a white rectangle for rectangular lights in the shots you shared. In the shot with glass surface I see reflection of the model in the window, but that is to be expected.

Hi Nathan,
Thank you for your prompt reply.
Indeed, reflections are ok but on the first screenshot and where the red circle is, you can see that the concrete texture is replaced by a white color, and it happens only when a glass surface is used. I didn’t have this problem previously. I have added additional pictures that are more explanatory. As you can see; without the glass surface, the rectangular light doesn’t show but once a glass material is applied, we can see a white rectangle.

Right, but as said, that is to be expected. Rectangular lights are visible in reflections, as are directional lights.

Ok but I was under the impression that they were not showing previously, and the scene looked more realistic. Is there a solution to lessen the effect because it doesn’t look right?
Thank you

At the moment there is no control over that for rectangular lights or directional lights. That is targeted for Rhino 9.

Point lights are not showing up because there were other issues involved there as well with those.

Ok, thank you. Hiding rectangular lights partly solves the problem but it’s good to know that this problem will be taken care of in the future.

V-Ray handles Area-lights differently and has also the much needed “directionality”-option as well as the possibility to use all Area-light as “Portals” to “funnel” light through windows and other openings. Sorry for the “non-technical”-wording and mistakes