Help using Rhino files in CAD assemblies

Is there a way to get rid of the seams in Rhino parts? I’m trying to use exported Rhino step files in other CAD but the seams in Rhino parts interfere with building of assemblies in Alibre and Onshape.

I have one part made in Onshape, one in Alibre and one, with the seam down each side, made in Rhino. As you can see in both assemblies the Rhino part won’t mate at the centre because it looks like one part cut in half

rhino2.stp (14.1 KB) onshape.step (5.0 KB) Alibre.stp (9.2 KB)

The Rhino stp file has a cylinder with two surfaces constructing the wall. If you make a cylinder with a single wall using the cylinder command does it mate better? If you can chain edges in these other programs to define the circle for mating try that too. It seems like they don’t see this as a circle due to the second surface edge.

I’ve tried making the Rhino part using the cylinder command and by extruding a circle and I get the same result. This was actually just a quick experiment to confirm what I suspected. Any parts I’ve made in Rhino in the past I can’t use in an assembly because the seams throw off the mating process.

I was wondering if maybe you had the split at tangents option enabled in extrudecrv but I’m so far not getting a second seam in the wall with any circles I’ve drawn here. The cylinder command also only creates one seam in the wall using Rhino 5 here. Are you getting two seams with both Cylinder and ExtrudeCrv? Please post the curves if you can and I’ll try to see why.

The Rhino stp file was an extruded surface. If I use MOI3D I only get one seam but it doesn’t work either for assemblies. I need zero seams.

Step usually splits closed surfaces. Have you tried a different file format, eg. iges ? You can control the split behaviour with every iges type in case your destination application reads that format. Below are settings used for IGES type 143.