HELP Needed with Ring... networksurface? sweep2?

Hi, I am having issues closing the surfaces of this ring. I have spent hours trying different things but it always ends up wonky. I have tried networksurface and sweep1 and sweep2, but nothing works well. How would you do that? Could you please try it with the file? I know how I want it to look:

I would be very thankful if you could help me with that.
Thanks, Katharina
RingKK.3dm (5.1 MB)

Hi Katharina -

That’s because your input curves are wonky.
Turn on the points of your profile curves to see what’s going on.
The ones at 1 and 11 o’clock have control points that are on the inside of the circular rail curves:

The one at 12 o’clock doesn’t have control points on that inside but clearly overlaps itself:

When I explode that curve, it creates 10 segments. There should be only 3.

Create the sides of all profile curves from simple 2-point lines and join those with a simple 3-point arc.
From the looks of it, the two rail curves should be simple circles, not curves with 35 points.

1 Like

I would use clean guide curves and surfaces to make the general shape easier to control with fewer control points if necessary.

RingKK Bobi.3dm (6.0 MB)

The modeling tutorial showing how I created the ring model above is currently uploading and will be soon available for watching here:

Note 1: This video was supposed to be much shorter, however, at the 27:30 minute there was an unexpected bug in one area of the blend edge surface that forced me to do some problem solving on the go and extend the modeling time. But I guess that this could be considered a nice bonus for the tutorial, because bugs like this one happen on rare occasions and it’s nice to be able to fix them using some alternative way of modeling.

Note 2: At the 39,45 minute I forgot to apply “Match surface” to the lower edge of the blend surface. :slight_smile: However, in this particular case that little mistake was not critical since the flow of the blend surface was already within the file tolerances, so it pretty much followed the same shape and continuity as the split edge underneath.

Note 3: Also, at the end of the video I decided to make the top blend surface more natural and smooth, so I re-trimmed the top trimmed surface via clean curves with minimum amount of control points and G2 continuity in the 4 corners. The change may seem subtle since this is just a small ring, but I thought that it would be nice to show an alternative way to improve that area, because the same approach may be useful for you on different projects with larger parts where the standard rough trimmed surface may cause issues due to the lack of natural flow.


Thanks a lot for your time looking at my file1 Got it: my profile curves are not clean and I make a note to self that less control points are better. I have improved the profile curves the way you suggested and was able to sweep2 the lower part of the ring shank as I envisioned, however still got stuck at the top part of the ring. Even with the corrected profile curves rhino doesn’t do what I intend to do, so I must have the wrong approach.

Oh my f****** goodness. You have no idea how excited I am about your video!!! I am speechless about how kindly you shared your knowledge and time with me. I have been sitting patiently and waiting for the premiere on youtube, but at the moment the quality currently is not good enough for me to see your commands. I think Youtube is still processing the video (at least that is what I just googled, that the better quality takes more time to process). So I will just check again later to see what commands you are clicking so I can follow along on my computer. I will comment again once I have worked through your video. But for now: I am soooo grateful.

1 Like

Yes, you are correct about YouTube taking longer time to process videos with good quality. My video is 4K at 60 frames per second. But the main reason for the extra long waiting is that I was unable to keep it within the one hour limit. YouTube puts any video longer than one hour in the waiting list behind many other videos that are shorter, even if they were uploaded in a later time. :slight_smile: Also, YouTube prioritizes 24, 25 and 30 fps videos over the 60 fps ones.
I tried to click slower and hovered the mouse pointer for a couple seconds on each icon to make it easier to understand the actions on the screen.
There was one bug that happened during the recording that was caused by some incorrect calculation by Rhino, so it’s yet another reason for the longer video as I had to figure out an alternative solution. :space_invader: :slight_smile:

Edit: Just checked and there is a 1080p version of the video already processed, some 5 hours after I uploaded the original. I suppose that the 4K version will take some extra hours.

You can also could download any YouTube video (as well as from Facebook etc) by using 4K Downloader. It’s free and easy to use - simply copy the URL address of the video and paste it into the program to download the video (or extract audio from it):

Hi Bobi, your video is amazing! I studied it for a couple of hours because there were so many commands I have never used. I learnt a lot! I am sure I will be re-watching it in the future. I loved to see your workarounds and it was encouraging to see that more advanced users also stumble across unexpected issues.

The file that you have uploaded is not a solid, but still open surfaces. As I tried to replicate your approach with another item and I got stuck at this step and it might be the same reason why your model is not a solid.

When I use loft to make the side surfaces and then change the curvature through adjusting the two middle rows of control points the edges of the surface shift slightly, so that there are gaps in between the different surfaces when I try to bollean union them/join them together. What would you recommend doing in that case?

I am very curious about how you made the preview picture of the ring. It looks sooo nice!!! Is it done with Rhino or another software like keyshot or sth else? Is that hard to do or could I learn that too?

Hi Katharina, I’m glad that you find my video helpful. I just opened the model again and figured that the problem comes from the simple fact that for some reason the “Rebuild curve” tool was unable to create exact symmetrical curves (at the 1:00:57 minute of my video) that I then used to split the top surface. That lead to a very tiny gap between two of the mirrored white curves and the green blend curves. I used the ! _Match command to make sure that each green blend curve properly matches the white curves, then I untrimmed the top surface and trimmed it again with the modified curves. Then, I applied “Match surface” to the blend surface (ir, you can build a new blend surface instead) and lastly, I joined the surfaces. This time, there were no tiny gaps.

Also, the angle tolerance was set to 1 degree in your file preferences (Rhino options > Units > angle tolerance), whereas I usually work at tolerance of 0,1 degree. That’s crucial when working with the “Match surface”, “Sweep 1 rail”, “Sweep 2 rails”, “Loft” and “Blend surface” commands since Rhino will try to obey the file tolerances upon matching the surface edges. 1 degree is way too loose and may lead to visible crease line between couple of matched surfaces.
I also recommend you to increase the display precision (from the same menu window) to the maximum of 1.0000000. That will help you notice some deviation easier.

However, I don’t know where your gap came from. It looks way too large. Are you sure that you used deformable circles as input objects for the “Loft” tool? The rounded surface in screenshot you posted above seems too off. Another possibility is that there is an accidental movement of a control point that’s part of the end row. Moving the two middle rows of control points of the loft surface should not affect the end rows.

As for the rendering, you guessed it right - it was made in Keyshot 8. Just a basic rendering. I’m pretty sure that a similar effect could be done in Rhino, though I have zero knowledge about rendering there.

RingKK Bobi.3dm (6.0 MB)