Help! Disappearing Drawing

Was arranging Drawing (after using Make2D) in Layout on page and suddenly all geometry is gone. Only lines left are Hidden Lines. Have tried to Undo but geometry won’t come back. Wondering whether I accidentally hit a viewport/hide command. Have looked through the command list and can’t seem to locate the command I make have made by mistake.
Any help much appreciated - second time this happened in the past few days!

Update: Trying to make remaining model into drawing (w/ Make2D) and can’t select it, even though it appears in all 4 viewports.

Solved: I selected the whole grid in Top viewport (which was empty apart from frozen model) and dragged, all drawings became visible again suddenly. Maybe this is because of the age of my mac (2015 SSD) but its funny that it all just disappeared?!

Hi Tanad -

It’s hard to tell from the description what’s going on there, but, yes, it sounds like a display issue of some kind. Please run the Rhino SystemInfo command and copy-paste the result here.

Rhino 7 SR27 2023-2-1 (Rhino 7, 7.27.23032.13002, Git hash:master @ 4a0030c0d354560df03764f4f49ecc5d119e5118)
License type: Evaluation, build 2023-02-01
License details: Cloud Zoo
Expires on: 4608575-04-15

Apple macOS Version 12.6.1 (Build 21G217) (Physical RAM: 8Gb)
Mac Model Identifier: MacBookPro12,1
Language: en-IE (MacOS default)

Intel(R) Iris™ Graphics 6100 (OpenGL ver:4.1 INTEL-18.8.5)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: Intel Inc.
Render version: 4.1
Shading Language: 4.10
Maximum Texture size: 16384 x 16384
Z-Buffer depth: n/a
Maximum Viewport size: 16384 x 16384
Total Video Memory: 1536 MB
Graphics: Intel Iris Graphics 6100
Displays: HUAWEI AD80HW (93dpi 1x), Color LCD (227dpi 2x)

Graphics processors
Intel Iris Graphics 6100 (1536 MB)
Color LCD (1280 x 800)
HUAWEI AD80HW (1920 x 1080 @ 60.00Hz)

USB devices
Western Digital: My Passport 25E1
Broadcom Corp.: Bluetooth USB Host Controller

Bluetooth devices

Third party kernel extensions (1.41) 55FCE530-B0B0-34B6-B6FA-A0E4FE88905B

Third party plugins

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
/Applications/Rhino “RhinoCycles” 7.27.23032.13002
/Applications/Rhino “Snapshots” 7.27.23032.1002
/Applications/Rhino “Grasshopper” 7.27.23032.13002
/Applications/Rhino “PanelingTools” 7.27.23032.1002
/Applications/Rhino “AnimationTools” 7.27.23032.1002
/Applications/Rhino “Commands” 7.27.23032.13002
/Applications/Rhino “SolidTools” 7.27.23032.1002
/Applications/Rhino “SketchUp Import” 7.27.23032.1002
/Applications/Rhino “Renderer Development Kit” 7.27.23032.1002
/Applications/Rhino “RDK_EtoUI” 7.27.23032.13002
/Applications/Rhino “Displacement” 7.27.23032.1002
/Applications/Rhino “Rhino Render” 7.27.23032.13002
/Applications/Rhino “IronPython” 7.27.23032.13002
/Applications/Rhino “Legacy Rhino Render” 7.27.23032.1002

Seems very underpowered for Rhino especially with a second display hooked up… (if I am interpreting the SystemInfo correctly)