Have Mac OSX 10.8.4 Rhino won't open


#1

The download says I need 10.7 Have 10.8.4 Why won’t it open?


#2

From the download page:

“Requires latest version of OS X Lion (10.7.5), latest version of OS X Mountain Lion (10.8.5) or any version of OS X Mavericks.”

–Mitch