Groups breaking upon selection V8

Ive posted before about this, with examples, not had any feedback.

So I’ve been using V7; a few days ago I started using V8 again, thinking the problem must have been solved, but it isn’t!

I have a set of objects that are grouped. I go to select them and, depending on where I place the cursor, the entities are either selected as you’d expect, or only partly selected.

The exact same entities, on the exact same machine, in the same session (ie pasted into previous versions of Rhino) behave as expected in V5, V6 and V7.
So it looks to me, on balance, that something is wrong with V8, rather than my machine, but what do I know…?

Anyway, I cant use V8 until this is resolved…


Yes, I still see this in the current V8 WIP. @wim - has this been buggified?

Hey all - I do not see this so far in a simple test - I group a bunch of objects and click on any one of them, the entire group is selected…? You see some objects selected, sometimes, or?


Hello Pascal - see my post “V8 group anomaly” of January 20, 2022…


Hi Tony- thanks, I see this.
Do you have steps to reproduce this situation predictably?

No, it happens so far within the context of quite complex models, and appears randomly.
The best I could do I suppose would be to try to analyse the file I posted, but likely you guys could do that much better than me…

But I’ll switch back to V8 and lookout for it as I’m working, and post back here if I find anything useful.
It might be a red-herring, but the object in the example file was derived from and simplified from an imported stp file - I could send you that original file if you thought it would help…?

Thanks Pascal

Hi Tony - Mikko’s fixed it…


(!) excellent (!)