Grasshopper preview visible in Rhino after closing GH window?

Hi @Dan, @curtisw, and everybody else,

In Rhino for Mac 5, there was a super useful feature, where you could minimise the Grasshopper window and the GH geometry preview in Rhino would stay active.
However when you closed the Grasshopper window with the top left X-button of the UI, the GH preview would disappear from Rhino (without entirely closing GH).

This was neat, since you could quickly hide the Grasshopper preview, to work in Rhino, without having to hide and unhide individual components all the time.

Unfortunately, this seems to have changed in Rhino for Mac 6 (6.17.19218.01052)?
When I close the Grasshopper window, the preview remains in the Rhino scene, as when Grasshopper is minimised.

Any chance you could bring something similar back?

@curtisw Do you think the behavior in Rhino 6 is the result of changes to keep track of gh-and-3dm for a multi-doc environment?

Actually, I don’t think I’m seeing this behavior. Let me triple-check. Indeed, I’m not.

Here are my steps to attempt to reproduce this:

  1. Launch Rhino 6 for Mac 6.17.19236.01022, start a new modeling window, and run Grasshopper.
  2. Place a Sphere component on the canvas.
  3. On the Grasshopper window, click the minus - button at the top left-hand corner to minimize the window to the dock. The Grasshopper generated sphere remains visible in Rhino.
  4. Click the Grasshopper window in the dock to bring it back.
  5. On the Grasshopper window, click the red x button at the top left-hand corner to close the Grasshopper window.
Expected Behavior

The sphere disappears.

Actual Behavior

The sphere disappears.

What are we doing differently, if anything?

I would like to also report this ! yes the grasshopper preview geometry still appears after closing grasshopper by the UI x button. However after closing, once I simply click on the perspective view or top view, the preview geometry disappears.
I am on 6.18 !

Nothing at all! I’ve replicated your process in 6.18, but the “issue” seems to persists.

This doesn’t happen for me. The geometry geometry remains previewed.

I tried to record it for you, but I couldn’t replicate too ! Now it seems to be working normally for me on 6.18. When grasshopper is closed, then the preview geometry disappears too !

Interesting.

Are you absolutely certain you are reproducing the above steps verbatim? Did you fully Quit Rhino first and launch it again? Perhaps you have multiple documents open?

We need to figure out what we are doing differently as I suspect that will give a clue as to where the bug lies.

No, I did this test this morning after freshly launching Rhino with a single new open document.

Wow, this is bizarre. Now I am able to reproduce what you are reporting in both 6.17 and 6.18 with the above steps. I’m going to do a bit more testing before I log this…

…and now I’m back to a state where I cannot reproduce this at all. Argh. I know I saw it once! :grimacing:

Something is clearly amiss. Maybe @curtisw will see something I don’t here.

1 Like

Hey @p1r4t3b0y and @dan,

Yes I can reproduce the same behaviour where the preview does not go away. The previous behaviour was actually the bug as far as I can tell - the GH window was marked as closed even though it was still in memory, so when you ran Grasshopper again it’d get a whole new window (and a memory leak).

We could possibly re-instate this behaviour purposefully in a future version, perhaps through an option. I’ve logged it here: RH-54706.

1 Like

I think that is the better way to go. If this is a bug that has been fixed, it should remain fixed.

Hey @p1r4t3b0y,

I was just perusing the code for another issue and came across the code for this feature. It is actually still there, but you have to close the Grasshopper panel for it to do this. It is actually the same behaviour as on Windows.

The difference is on Rhino v6 the Grasshopper panel is shown by default, whereas on v5 you have to explicitly add it.

Hope this helps!
Curtis.

Yes, in fact you have to close your current Grasshopper document (CMD + W) completely. I guess that’s what you mean by “panel”?

OK, well I guess that means that this behaviour is gone for good?
If it was a coincidental bug, I must say that it was in fact a super neat feature! It immensely sped up switching between an exclusive Rhino preview, and Rhino with the Grasshopper preview overlaid.

I’d love it, if you guys thought about reimplementing a similar feature in future versions.
At the moment, toggling the geometry preview in Grasshopper, and then minimising the window works, but it entails an additional step, compared to just closing or minimising the window like before.

In Rhino for Mac (6.18.19266.13352, 2019-09-23), there also seems to be a minor bug or feature missing, where I’m unable to minimise the Grasshopper window with the shortcut CMD + M (which is the macOS minimise shortcut of sorts).
Weirdly enough, when I have the Rhino window selected, it can be minimised, but the Grasshopper one stays afloat.

I know that 6.18.19 is not the latest version, but after the major bugs in its antecessor, I wasn’t to keen on updating so far.

@dan and @curtisw, thanks for your support! You guys are great!!

I just tested some of @curtisw’s fixes for this. It was bothering me too. Expect to see this fixed in 6.20. In 6.20, Grasshopper’s window behaves much more like a normal application window.

1 Like

Hey @p1r4t3b0y, no this feature is still there! What I mean by closing the GH panel is this:

DisableGrasshopperPanel

Oh, nice! Thanks.

1 Like