Grasshopper icons disappearing from Canvas

Hello GH community,

I am having a trouble in my Grasshopper 10.0007 in Rhino 6 for Mac. The components are added into canvas are not being displayed. It just started occurring during the work and I tried restarting the program which did not help. I have no idea what could be the reason, but it seems when I pan around or zoom in too much, I can see the trace of the components and then they disappear again. Here you can see how it looks.



I’d appreciate any help that can fix this issue.

Thanks in advance

Presumably this is happening because some component which is drawn prior to the missing ones is generating errors thus causing all subsequent ones to not draw at all. Based on your video my bet is on the Graph mapper. Is there any information written to the command history which might narrow it down?

To test this, you can try and move different object to the front of the stack (Ctrl + F). This will cause them to be drawn last. It should help you figure out the offending object.