Grasshopper - Archicad live connection Anchor Point

Hello to everyone,
I am experimenting the Grasshopper - Archicad live connection and I have a question regarding the Object Anchor Point. Despite in GH it is possible to define the Object Anchor Point directly from the Rhino model geometry, in Archicad, when the Object appears in the Library, the Object Anchor Point appears in a completely different position. It looks like they are two different things. Does anyone know what I am doing wrong? If you have many objects, editing Anchor Points individually seems to be quite a time consuming and unnecessary process. Many thanks!

@Japhy - do you have an idea?

-Pascal

luca, I’m not familiar with Archicad or the anchor point, but it sounds similar to other origin point problems.

When creating the anchor point in GH what are the geometries relationship to 0,0? It may need to be moved to 0,0 to be used as the anchor point when creating the object.

Thanks Japhy. The object is fairly close to the Rhino 0,0 origin.

Yes, but can you use the orient 3d component to translate the geometry from the desired Anchor to 0,0 then create the object from there? with 0,0 as the anchor. This is what’s needed in similar situations.

Thank you. I will try that.

Is the current Anchor Point coming from a point or plane? Depending on the geometry a point vs plane could give you some unexpected results.

Hi Japhy, Apologies for the massive delay. As an anchor point I gave a point, as this is what Grasshopper seems to ask. However, for some reasons, by moving the object to 0,0, today it worked. I will keep you updated.

Hi again,
The highlighted problem seems to reappear (regardless of the input geometry).

I attach a simple box (which is supposed to appear in Archicad 25 as an object in the library), the grasshopper definition, linking GH to Archicad and screenshots of what I am experiencing. My understanding is that the problem may be related to the anchor point, which is clearly shown in the short bottom edge to the right side of the box.

  1. In the grasshopper definition, the Rhino input geometry is supposed to become an Archicad object.

However, the resulting object seems to be made of 2 objects: one is the input geometry (the small box to the bottom left of the image below), the second one is a much bigger ghost box (clearly visible). If the anchor points is deleted, also the ghost box disappears. This ghost box can be selected, made to disappear (with the preview option disabled) and can also be baked and become a (unwanted) real geometry!

  1. In Archicad, the object, which can be now found inside the Embedded library, similarly, appears as 2 elements: the original Rhino box geometry (the small green rectangle in the bottom left) and the ghost box, not visible, but present. In fact, the anchor point, supposed to be set attached to the original box geometry, is instead shown in a corner of the ghost box (upper right corner).

Updating the object name etc… doesn’t seem to appear in real time in Archicad.

Is this a bug or am I doing something wrong? Is anyone experiencing the same?
This GH to Archicad connection is supposed to work on much more complex parametric definitions, so I am quite surprised.

Thanks

Luca

Box - Test 01.gh (10.5 KB)
Box.3dm (53.3 KB)

Not sure how much help i will be here, Archicad is a bit out of my arena.

I think there might be a units issue which is generating the large box, the project file is in MM.

can put the origin of the box at 0,0?

Thanks, Japhy. I have just tried, but the shadow box still appears. If I delete the anchor point, also the shadow box disappears.

Hello.
You can turn on the Detailed Archicad Preview toggle in Grasshopper’s Display menu.

Thanks, it doesn’t seem to be a problem of visualization, but of creation of an unwanted ghost box.

Can you send me your .gh?

Of course.Box - Test 01.gh (10.5 KB)
Box.3dm (64.1 KB)
Thank you
Luca

Box - Test 01.gh (10.5 KB)
Box.3dm (64.1 KB)

Hello Luca,
I didn’t see what’s wrong, I didn’t see the ghost box either. But one thing is essential: before creating your object, move its geometry to the origin (0,0,0). It will be the insertion point of it in ArchiCAD.

Thanks very much Felipe. I got it to work with this method.
However, just to clarify, did you leave the P value (the anchor point) as unspecified, in the Object component? Are you not getting the warning?

I’ve just made a right-click and Set a point in Rhino.

Thanks Felipe, the question was if in your definition you set the point input or not, to avoid getting the weird ghost box and have the correct result in Archicad.