glTF 1.0/2.0 binary (ShapeDiver) export option missing

I have a question regarding the installation of shapediver. I used to get the rhino export type of “glTF 1.0/2.0 binary (ShapeDiver) (*.glb)” when I install shapediver. Recently, I am unable to get that option in the rhino export types.

I tried installing shapdiver (.exe) and also adding the (glTF-BinExporter) from the rhino package manager but non of them worked.

I am using Rhino 7 on Windows

Do either of the plugins appear in the plugin manager list?

1 Like

Thank you for your prompt reply Joshua.

Yes, it appears in the plugins:

But the “glTF 1.0/2.0 binary (ShapeDiver) (*.glb)” doesn’t appear in the export types:

The “glTF Binary File” and “glTF Text File” are from the glTF-BinExporter plugin. That appears to be working correctly for you. As for the ShapeDiver plugin you’ll have to see if it’s in the plugin list and loaded. I was able to load both plugins and both export options appeared.

I’m guessing the ShapeDiver export plugin isn’t installed/loaded. You can do that by clicking install in the plugin manager

Then select the ShapeDriveGltfExporter.rhp. For me, when installed with the ShapeDiver installer, it was located at:


1 Like

Thank you, Joshua, that worked perfectly!