GH preview is see through rhino geometry

Grasshopper preview geometry is always visible, even when behind the Rhino geometry. Is it a hardware problem? Is there a way to fix this?

Windows 7
GeForce GTX 960 - driver version 416.34

Turn off bump preview.

1 Like

Thanks Michael, it worked like a charm. Will keep this in mind.