Bump preview problem

unhandled
preview

#1

What has happened to bump preview in GH 2?

I have some display issues, which I think were solved with bump preview in Rhino 5.

The screenshots show Rhino 6 geometry with dots and line dimensions from grasshopper. The dots are only visible when there is nothing behind the dot. The number is visible in white font all the time.

I need the geometry to be visible and selectable. Using a custom material in Grasshopper does not solve the problem. Transparency kind of helps.

Changing transparency to 1 kind of solves the problem for now, however another issue arises. The dots aren’t shown when there is more than one object behind it.

It would be nice if the dots were in front of my geometry.


#2

Dear David, I’m really struggling with the issue above. Any info, whether this is a general problem or something I’d need to solve in my settings would be appreciated. Actually, that quick fix with turning transparency to 1 doesn’t work anymore with the latest service release candidate.

Another small issue: space bar doesn’t show the wheel menu anymore. Maybe you guys could turn that back on. Thanks


(David Rutten) #3

Bumping everything all the time was causing a lot of trouble. Lighting, z-clipping, there were weird edge cases all the time. Previews are still bumped now but only when the component drawing them is selected.

Yup, space bar now shows the create menu, seemed to make more sense. Middle-mouse-button still shows the radial menu. If you really want to revert to the old behaviour, you can edit the settings xml file. Look in %appdata%\Grasshopper\grasshopper_kernel.xml and find the following entry:

<item name="Canvas:SpaceIsRadial" type_name="gh_bool" type_code="1">false</item>

Change the false to true while Rhino isn’t running.


(David Rutten) #4

I’m not sure who’s drawing the textdots. If that a plugin component, or are those standard Rhino text dot objects?


#5

Thanks for your quick reply.

The text dots are created with elefront and fed into a custom preview component with a color swatch, so that the text dot has a distinctive color.

I’m using grasshopper in conjunction with rhino geometry so I can quickly edit geometry. On the screenshots above you see a rhino mesh, which is referenced into GH and kept up to date with a timer. The mesh goes through kangaroo and is being baked with a name with an elefront bake component. This replaces the input mesh from before. It’s like a loop.

For me, it is important to have dimensions and text dots on top / in front of rhino geometry cause I work with rhino geometry all the time. Of course I can set the viewport to wiremesh mode and apply a transparent preview color to the mesh in GH. That solves the issue with the dimensions and text dots. However that way it takes two clicks to select a mesh face via a boundary…

I understand the issue with keeping the text dots and dimensions in front of other stuff.

But the situation right now, I think is terrible to look at. I tried moving the locations of the dots away from a surface but nothing helps a dot is only drawn with a frame around it and a color when there is strictly nothing behind it. This is terrible to look at and kind of not what I expected from a dot. Isn’t a dot always in front of geometry, I mean also in Rhino?

I’m working with GH for about 7 years, it would take a while to switch my brain from space bar to middle mouse button. Hence I did switch back to Space is Radial, especially because my middle mouse button creates a double left click. I’m using a 3D connexion CAD mouse.


#6

David,

“Selectable Preview” is able to create a textdot infront of everything else. It basically bakes geometry to a layer. Once a text dot is baked, it’s in front of everything.

It’s a very old component inside Grasshopper.

I really think you should implement something like the arrange command into Grasshopper. Maybe not the way it was before with an overall bump preview, but with a special preview component.


#7

On the image, you can see four surfaces in wiremesh display mode

Text Dots created with the Text Dot component out of the latest elefront tab.

They are visible as rounded rectangle, here with custom color due to custom preview.

Once I bake the text dots I can read the text, but only then.

Someone please fix this.
Thanks


(Laurent Delrieu) #8

Hello
I think I have the same problem, also with Text Tag
I just view the text when baked !!!
On this image the Text Tag is not near the upper point
Text Tag 3d is working !


#9

Yes the normal text tag 3D works, however I need this text as a solid to create engraved text. Will have to bake it and do it manually.

It would be great to have a creat text component with an output…

I did also find a python script to create text and there is a component inside fab tools to retrieve the outlines.

More efficient as mentioned above would be a real text component where you can choose what to output and also do something with it without baking.

Please :rhinoceros: :heart_eyes:


(Laurent Delrieu) #10

For engraving single line text I use Bowerbird BB Text. Elefront has also a bake-able text component.

But the first problem is that it seems to be a bug in Rhino/Grasshopper SR4 with Text Tag and Text Dot.


#11

In Elefront, I am using Rhino.Display.DisplayPipeline.Drawdot to preview the text dot.
In the current release of Rhino 6, there are two problems with this method.
1.The textdot is always drawn behind any Rhino geometry even if the physical location of the dot is in the front of the geometry.
2. The text in the text dot disappears even if I set the text color different than the fill/dot color.
This is more of a Rhino Common problem than a Grasshopper problem.

Alan


#12

There is a work around for everything.


#13

Alan, thanks for your replies.

Any chance you could implement the style of the text in the text tag 3D component? Like solid, curve or surface?


#14

Dear Rhino developpers, how can I display Grasshopper geometry, text and what else in Rhino Arctic mode?


(Tim Stark) #15

Custom preview component. It‘s reworked, when you right click on it, you‘ll see an option: render preview


#16

And text?