Layout preview geometry bug with Grasshopper (Rhino 6 SR12 2018-12-17)

Happy Christmas everyone!

Last few hours of work for me and was about to send some orders out but I can’t :confounded::sob:

With the latest build all layouts preview went bogus with grasshopper
Can’t see any of my 3d text tags.
All I’m able to preview is geometry with custom preview shader in Rendered or Raytraced layout using

Rhino viewport

Layout in rendered

Layout in shaded

Rhino 6 SR12 2018-12-17 (Rhino 6, 6.12.18351.21491, Git hash:master @ fae245659fd30c6dad38c0c2b889629254cd7e73)
License type: Commercial, build 2018-12-17
License details: Cloud Zoo. In use by: Lukasz Domagala ()

Windows 10.0 SR0.0 or greater (Physical RAM: 16Gb)
Machine name: DESKTOP-7HB274K

Non-hybrid graphics.
Primary display and OpenGL: NVIDIA GeForce GTX 980 Ti (NVidia) Memory: 6GB, Driver date: 12-11-2018 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 417.35

Secondary graphics devices.
NVIDIA GeForce GTX 770 (NVidia) Memory: 2GB, Driver date: 12-11-2018 (M-D-Y).

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 12-11-2018
Driver Version:
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 6 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.12.18351.21491
C:\Program Files\Common Files\McNeel\Rhinoceros\6.0\Plug-ins\Thea For Rhino (0ab51401-0ca2-45e3-94e0-46d77b129353)\2018.3.18.0\Thea_V2\TheaForRhino.rhp “Thea For Rhino”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.12.18351.21491
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\IronPython\RhinoDLR_Python.rhp “IronPython” 6.12.18351.21491
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.12.18351.21491
C:\Program Files\Rhino 6\Plug-ins\Grasshopper\GrasshopperPlugin.rhp “Grasshopper” 6.12.18351.21491
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.12.18351.21491
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Users\lukasz.DOMAIN\AppData\Roaming\McNeel\Rhinoceros\6.0\Plug-ins\OctaneRenderForRhino (f109bd23-4cf3-4c0b-9f83-06be474b0152)\\RHI Installer 6\Rhino 6.0\x64\OctaneRenderForRhino.rhp “OctaneRenderForRhino”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\XirusCAD\\v6\Xirus.rhp “XirusCAD”


Hello - thanks, added


1 Like

Hi @pascal
Thank you. I’ve checked myjetbains but it’s not only text tag issue. You also can’t see breps in layout unless custom preview component is used.

@velopl, from the YT, I see that the issue with the text tag is solved to be tested internally.
I tried reproducing the problem with the brep but the preview is visible in a wireframe detail here.

You could test with the daily that I’m running to see if the problem still occurs on your end.

Hi Wim

This is behavior of rhino_en-us_6.12.18351.21491

6.12 viewport

6.12 layout shaded

6.12 layout rendered

I will check now your daily (3.9 KB)
test_layout.3dm (27.0 KB)

With rhino_en-us_6.13.19003.04411 all back to norm thank you :slight_smile:

1 Like

Where did you download rhino_en-us_6.13… ?

From my link above.

This will also be fixed in the next SR12 release candidate that we should be shipping this week. The link provided was for SR13 which we won’t be making available until we have finaliized SR12.

1 Like


RH-50142 is fixed in the latest Service Release Candidate