FLOW and twist

i am trying to create a flow along curve to an object on a curve. the object is not twisted and i dont want it to twist, but when i am trying to create flow along curve its creating a twist.
why is it Happens? and how can i overcome the problem?
pic attached…

kinky curves maybe. you can post the file if you want.

1 Like

Have a look here: Command: _Flow

@pascal - is this still on the pile for V6?



Hi Andy- it is fixed in V6, but requires a ‘roadlike’ option in Flow, which makes it possible but a bit more fiddly, to get the right answer in these cases.

For now, @al_davidson - turn the path curve 90 degrees to lay it down in the World Top CPlane and see if it behaves better (I’m just guessing, not having seen the curves)


1 Like

@pascal i am wondering if this has anything to do with how the vectors get calculated and summed up. in other software this has the same behaviour which seems normal but can become troublesome trying to set up camera animations which go overhead and down again. there this is being fixed with using an extra up vector.

after fiddling around a while till i got one that kinks i tried offsetting it which shows that shifting into z is being handled with flowing around in a circle instead of flowing up straight. so maybe flow has the same “issue” as offset. i guess a “roadlike” option does nothing else than adding an extra orientation vector. so maybe this can become usable in future… but then also offset please, i had some incidence where a proper offset would´ve saved me a lot of work.

Hi Richard - offsetting curves in Rhino is a planar operation - to offset 3d curves in a sort of predictable way, Pipe (= 3d curve offset) , then extract a convenient isocurve…


you mean as planar as flow? :smiley:

yes thats how i did it, but its not very handy when you need a few of those and mostly pipe does also not deliver the offset curve i would want.

maybe it would be an idea to have the option to choose directional vectors while offsetting?

thanks everyone for the help!
2DCube, thank you for the explanation.
it is working fine now.:slight_smile:

1 Like