Flow Along Curve issue


Very new to Rhino and am trying to use the flow along curve but its not working most of the time and Im unable to replicate successful attempts.

I’ve piped a spiral and am attempting to have it deform along the target curve. I’ve drawn a polyline with the original model to use as reference when doing the flow command. The issue is that the end result is often not deformed in a manner, often times looking like its been sheared or simply rotated to an average of the curve instead of being fitted. Am i doing something wrong?

Is Rigid=Yes in flow? Flow | Rhino 3-D modeling

No rigid is unchecked. The only options i play around with are copy and stretch

Upload a .3dm file with the object to be flowed, the base curve, the target curve, and result you are getting. You can upload a file using the vertical arrow icon above where you type a post.

This describes the result of flowing a single object with Rigid=Yes, although there may be a different cause. You may want to double check that Rigid=No.

Can confirm that rigid is unchecked. Have tried to use flow with another open surface and am getting the weird shearing effect again.

flow small.3dm (4.1 MB)

I use Windows, not Mac, and am unfamilar with the Mac interface. There is nothing about the Rigid option for the Flow command in the image you posted. The only check boxes I see are for Osnaps and the options for the Shade view mode.

In your file the line and the adjacent piped helices are grouped. If the line is to be used as the base curve in Flow then it needs to be separate from the object to be flowed.

Many Rhino commands have options. Selecting the right set of options to achieve the desired results is an important part of success with Rhino.

Ok the base curve being in the same group as the object might be the issue i guess.

Hi -

Yes, it is. When that line get selected as “an object to flow”, you can’t also select that as the “base curve”. You can keep those grouped and either sub-object select the spiral object when prompted for objects to flow and then sub-object select the curve, or, if you also want to flow that curve, use the Line option to set the line when prompted for a base curve.

Ok tried that, didn’t work. I think im selecting something wrong when prompted to draw a line. I’m not able to deform properly either with another open surface object that does not have a base line in its grouping.

Hi -

Three different things were suggested - I’m not sure what you tried…

There are many objects in the file that you posted previously. Can you post a file with just (1) that object to flow, (2) a base curve, and (3) a target curve?

Ok i’m an idiot. Turns out I was selecting the target curve and base curve in the wrong order. Thanks for the patience everyone.

1 Like