Flickering Issue Ghosted (transparent) View

I assume this comes from intersecting surfaces, is there a way to keep the transparency settings but do not have everything flickering?

Thank you

Hi Hannes,

Can you run the systeminfo command in the Rhino command line and post the results here? Thanks.

@Japhy sure!

Thanks for helping me

Rhino 7 SR28 2023-2-27 (Rhino 7, 7.28.23058.03001, Git hash:master @ 4ffc5d7156fbccf2a5d9fcc80e522b3851bc7f6c)
License type: Commercial, build 2023-02-27
License details: Cloud Zoo

Windows 11 (10.0.22621 SR0.0) or greater (Physical RAM: 64Gb)

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: NVIDIA GeForce RTX 3080 (NVidia) Memory: 10GB, Driver date: 3-16-2023 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 531.41
> Accelerated graphics device with 4 adapter port(s)
- Windows Main Display attached to adapter port #0
- Secondary monitor attached to adapter port #1

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 3-16-2023
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 10 GB

Rhino plugins that do not ship with Rhino
C:\Users\hanne\AppData\Roaming\McNeel\Rhinoceros\7.0\Plug-ins\KeyShot12RhinoPlugin (78243fe3-17a0-4865-b713-88b4c224c48c)\\KeyShot2023RhinoPlugin\Rhino 7\KeyShot2023RhinoPlugin.rhp “KeyShot12RhinoPlugin”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.28.23058.3001
C:\Program Files\Rhino 7\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 7\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino 7\Plug-ins\RhinoLabsTools.rhp “Rhino Labs Tools”
C:\Program Files\Rhino 7\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 7\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.28.23058.3001
C:\Program Files\Rhino 7\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.28.23058.3001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.28.23058.3001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.28.23058.3001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 7\Plug-ins\Calc.rhp “Calc”

I recently installed a explosion rvb from food for rhino and it is for Rhino V6 - can deactivate with checkmark but not uninstall. How do I uninstall these plugins. Thank you

please go to you File>Properties>Plugins and disable the Keyshot and restart Rhino

Properties > Plug-ins you can locate it, right click and choose Properties - there you will be able to see the location of the rhp (plug-in) file. You can remove it from there as one way to uninstall (if not via package manager or accompanied by an uninstaller)

@japhy did not help. But thank you. Good to know. Can you estimate what the problem could be?

These are default display modes?

is it only in a particular file?

not necessarily default, but maybe defaults even if edited.

my reference was per a particular instance where one mode may be calculating render mesh and upon failure or time-out, Rhino will switch to X-ray mode to bypass render mesh calculation – I think.

Yup, there is the command ClearAllMeshes that wipes and puts the user in wireframe.

If its a particular file the first thing to check is SelBadObjects.

1 Like

Deactivated Plugin issues are the same x-ray

X-ray is not related to file but everywhere. It’s in a viewport view with custom settings, a similar view with only shadows turned off does not have the issue.

Flickering in custom ghosted view is solved as I changed the transparency and color values for locked objects.

I believe it is a custom viewport settings which will be corrupt, as they are only settings I don’t understand why this custom view that generates these x-ray issues will be corrupted at all.

But I simply will copy the similar version and set it as another custom viewport (with shadows) to have the state and all its previous settings back.

Thank you

1 Like

Worked for me.

What worked?

@lander Copied and renamed a slightly different but working display style and switched on one or two parameters (turned on shadows etc).

Everything works like a charm again.

1 Like

That’s one of my favorite things to do to the “Rendered” display mode :slightly_smiling_face:
It unlocks the shade object setting and rendering material, and has alot of settings I like that other modes don’t have.

@lander tested the viewport settings files from @Rhino_Bulgaria and they are way better.

1 Like