Flamingo nxt 5.5 with Rhino 6 becomes incredible slow!

Since I upgrades Rhino 5 to Rhino 6 and NXT 3.1 to 5.5, the Flamingo-Panel in Rhino became 5 times slower than before. So just changing the Resolution size in the rendering settings by typing numbers takes about 10 seconds for every single number (e.g if I type 2000, I type 2 - wait 10 sec- then type 0 - wait 10 sec- …)

Are there any settings to be changed to receive a better performance? or at least get back to the performance I used to have with Rhino5 and NXT 3.1 ?

Same problem here and today the few plants we have access to disappeared. I am stuck now with several architectural renders to produce and an extremely sluggish program. My Dual Hexacore beast computer can’t handle it. And no plants, that is a deal breaker. What gives?