File Thumbnail - Blurred Image


#1

Is anyone else having this problem? All new Rhino files I draw produce thumbnail images that are consistently blurred. See attached image to view the rhino interface next to its blurred file preview. Older Rhino Files are still very clear and are not affected. This problem only occurs when I save in the latest Rhino for Mac.

I have been receiving these poor images for a couple months now, thru a number of updates.

All of my preferences were deleted and refreshed in the example shown.

And this thumbnail problem only happens with Rhino on my computer. All other files appear as they should.

MacBook Pro Laptop Retina 15" 2.3 i7 Mavericks 10.9.2
16 GB Ram - Nvidia GT 750M 2048 MB


Large Quicklook preview missing
(Brian James) #2

Thanks for the report… I see it here too and made sure it’s filed for our developers.


#3

i’m not 100% on this but just going by what i see between a computer running 10.7 and one running mavericks…

it seems it’s something to do with the OS.

instead of using coverFlow as you’re showing on the right side of your screen, use quickLook… select the file then press the space bar…

you’ll see that on mavericks, the thumbnail is maybe 256px wide (then you’re stretching that out in coverFlow which is why it’s appearing blurry)

if you do the same thing on Lion to the same file, the quick look image is much larger and therefore appears much cleaner in cover flow…

anyway, i don’t know a solution or a cause… just pointing out that there is a difference which is happening in mavericks.



here’s a quickLook with a file on my mavericks computer (1680x1050 screen size)

…and here’s the same exact file (it’s a file in my dropbox) when quickLook’d on the computer running Lion (1920x1200 screen)


(Marlin Prowell) #4

I cannot duplicate this. I need more information. If you are having this problem, please post your OpenGL settings. Also mention if you have any custom display modes, or if you have modified any of the standard display modes. Please also name the display mode in use in the active viewport when you save / autosave your model.


#5

so you get large quickLook/coverflow previews?

would there be any osx differences with you on a retina mbp?

i wonder if this is somehow related to the black thumbnails I get sometimes?
(which I’ve tried over and over to get something repeatable to no avail)

I’ll try running rhino with a clean plist later today to see if anything changes regarding thumbnail size.

[edit]
oh-- but also notice the difference I pointed out between lion and mavericks.

I can create/save .3dms on either OS and they will behave the same when on the other OS… lion always shows large previews… mavericks always shows the small ones.

[edit2]- but that doesn’t happen with other apps with quicklook generators(?)…
pages, numbers, preview, text edit, etc still show the large previews in mavericks.


#6

hmm… yeah… i think i’m adding bad info to the thread… for one, i’m mainly talking about the size of the thumbnail when using quick look (select file -> push space bar)… on mavericks, that thumbnail image is small… but, if i look at it in coverflow, (finder -> show items in cover flow), i can enlarge it to the full screen size and the image is clean… in other words, i also can’t duplicate what bule is showing…

before reaching the conclusion that i don’t have the problem that bule is showing, i made a test account… (all clean prefs both OS & rhino)…

but that’s the same thing i get in my normal account regardless of rhino display modes etc (ie- i can save one in ghosted mode as bule is showing or even a modified version of ghosted)…

and i’ll still get a clean coverFlow image and small (compared to lion) quick look preview…


#7

Jeff - I get the same size preview window when hitting my spacebar that you do, but this does not affect the blurred image in the preview. The attached screenshot also shows my cover flow image reduced much smaller in size… but even then, you can still see the vertical jagged edges.

This is not a resolution issue, I am not scaling the image up ridiculously.
Also, the image quality is jagged only vertically, not horizontally. This is consistent


#8

right… i see what you’re saying and it’s not what i was originally talking about (i.e.- i screwed up the thread)

it looks like your thumbnails are bad even at small sizes… for me, in coverflow, i can make the previews as big as the screen and they’re still clean…

you should probably do what marlin suggested:

the openGL settings can be found at Rhinoceros-> Preferences-> OpenGL.
at the bottom of that window, there’s a ‘copy to clipboard’ button… paste that info here along with any of the other requested info you can provide.


#9

Software information

Software versions
Rhinoceros version: 5.0 Wenatchee 2014-04-21 (510)
OS X version: Version 10.9.2 (Build 13C1021)

Plug-ins
None

Hardware information

Computer hardware
Hardware model: MacBookPro11,3
Processor: Intel Core i7-4850HQ CPU @ 2.30GHz
Memory: 16 GB
Architecture: Intel 64 bit

Video hardware
Graphics: NVIDIA GeForce GT 750M 2048 MB
Memory: 2048 MB
Screen size: 1920 x 1080
Displays: SONY TV

Third party kernel extensions
com.razer.common.razerhid (9.4)

USB devices
Apple: Internal Memory Card Reader
Razer: Razer Naga
Apple Inc.: Apple Internal Keyboard / Trackpad
Apple Inc.: Bluetooth USB Host Controller

Bluetooth devices
Cambridge Silicon Radio:
Apple: Apple Wireless Keyboard

OpenGL information

OpenGL software
OpenGL version: 2.1 NVIDIA-8.24.9 310.40.25f01
Render version: 2.1
Shading language: 1.20
Maximum texture size: 16384 x 16384
Z-buffer depth: 24 bits
Maximum viewport size: 16384 x 16384

Implementation settings
Use texture compression: No

Appearance settings
Antialiasing: 4x
Mip map filtering: None
Anisotropic filtering: None


#10

Display Modes - My images turnout this way in all 8 standard modes. Perhaps this shot in Artistic mode shows the problem the best. Note the graphic is affected vertically and not horizontally.


(Marlin Prowell) #11

This is still something that is not happening for anyone else, so it is very hard to find a solution.

  1. Try creating a new user on your computer and running Rhino when
    logged in as that user.
  2. Try running Rhino on another Mac.
  3. You are running your MacBook Pro with the lid closed. Unplug your
    external monitor and run only on the laptop screen.

#12

Sorry for the delay Marlin… I tried all 3 of your suggestions without success.
I was able to download Rhino on my daughter’s iMac computer and it does not produce the same jagged images. The new user on my machine produces the same preview images.

With my computer I reviewed what adjustments I have with graphic oriented options that might be the problem? I recall my computer has 2 graphic cards… and in System Preferences / energy saver / I turned off Auto graphics switching. That did not fix the problem, but I wonder if it has something to do with this? Thanks for your help


#13

This issue has been solved Marlin with your latest update! Thank you