File Saved 100% —> Machine crashes —> Open Rhino, nothing saved?

So this happens to me more often than not:

I type _Save
File get’s saved.
I continue working for a while, my computer randomly turns off for some reason (totally unrelated to Rhino).
I restart computer and open my file,
I am being presented with an older saved file, my “saved work” is simply not there.

Anyone else experiencing this? It’s super frustrating, not sure how _Save and _Open functions work, but seems like something is seriously wrong here…

This is a general complaint, not a specific issue.

Hei Julian -

I agree that there is something seriously wrong, but if this were a common issue, this is something that would be very high on the agenda. I can’t say that I’ve heard about this particular behavior before.

I see that this topic has both the “windows” and “mac” tags - on what platform are you seeing this?

Have you had occasions, when you don’t crash but just exit Rhino and then later open a file again, that the file is empty?

I don’t see any crash reports from you. Please always send those in when the crash reporter pops up. Or, is the crashing of the machine not related to Rhino?

This happens ‘often?’ due to a ‘monitor issue?’ That doesn’t sound good at all.

There is apparently an issue with current Macs that they don’t really care about your data and this can “easily” happen, it’s very lackadaisical about finalizing cached writes, but it’s still not really something you should see.

Where are you saving the file to (e.g. internal hard drive, external drive, memory stick, network drive, cloud storage)? Do you perchance have cached writes turned on for that drive (unwise)?

How long after a save before a crash?

Thanks and sorry for the confusion, I’m experiencing issues with Windows, and it’s not a crash. It’s just that sometimes my computer randomly turns off, and in those cases I sometimes are given an older save when opening Rhino. Rhino does not prompt me with a crash report when I reboot, so I have no way of providing that…

The computer shuts down randomly, but that is a separate issue. I figured the issue here is that Rhino does not provide me with the saved file on reboot, where does the saved file go?

So the way my computer shuts down in this scenario is that I’m streaming a high performance Shadow computer ( for $30/month on my MacBook 11", and running Rhino effectively on a server in France. My external monitor has a weak cable, when I accidentally touch it lightly, the monitor resizes the window, the Shadow streaming app gets confused and closes all programs and shuts down. This may seem like a weird setup, but it actually saves me a bunch of money as an architecture student…

I’m saving my files directly in the cloud (Google Drive), I’ve been working up to 5 minutes after a save on this issue. Do you think it could be a lag uploading to cloud? Actually didn’t think of that… o.O

I would bet Google Drive’s cache is handled improperly. :thinking:


Well the problem is that running Rhino in a virtual machine is unsupported, and this shows why. This is obviously not really a “Rhino” problem, it’s one of fifteen thousand other possible issues, there is literally nothing anyone here can offer for advice, you have to talk to the Shadow people first, and they will probably have no answer for you. Have you checked how long it takes for your files to actually get synced to Google Drive?

1 Like

Have you considered replacing the monitor cable?

Just to be clear: you mean that Rhino is running on the Shadow VM and saving from there to Google Drive? Given that the Shadow VM includes some storage I would save there from Rhino instead, then manually copy that file to Google Drive at the end of your session.

I’d also record the file size after you save from Rhino so you can check that the Google file is completely copied.

I don’t think there is such thing as actually saving ‘directly to Google Drive,’ outside Google’s apps, it’s saved “locally” and then uploaded.

I run Google Drive on my local machine, and it takes few minutes for larger files to be fully uploaded to the server, so I guess you are saving locally, but your machine reboots before your file is fully uploaded to google drive.

For your Shadow Tech machine, after reboot, do you get a fresh OS installation? or you are still able to access your user data before the reboot?

The Autosave file will be in the location specified in:
Options > Rhino Options > Files > Autosave > Autosave file

Whether it exists when you Shadow Tech virtual machine restarts depends on how that is set up.

Hi @JimCarruthers,

In Google Drive For Desktop (the version that came out last year) on Windows the mechanism is transparent to the user. They see the Google drive as just another drive in explorer and can save to it. The Google software handles the caching and sync processes.

You can choose whether your files are streamed on demand (i.e. stored in cloud and copied to your PC only when needed - e.g. by opening in Rhino) or mirrored (i.e. a copy is permanently available on the PC so it can be edited when offline).


Yeah that’s what I meant. The OP seemed to believe “Saving to Google Drive” actually meant working directly off the cloud drive with no local saving.

Anyway, all this discussion has shown is why VM’s aren’t supported. We still don’t really know what the problem is, we didn’t even know there was one involved until Day 2, but it’s not actually a Rhino problem. It’s just been a waste of time, a rolling indictment of what VMs are supposed to actually accomplish.

1 Like