File preview stopped working


#1

I’ve been working over my home wireless network on a Macbook Pro on a number of files that were located on the internal hard drive of my iMac. File preview on finder was working fine, but I made some amendments (on the Macbook) to the files yesterday and as I saved them the previews turned black:

I’m now working on the iMac and despite refreshing the files from the iMac its still the same. All the file previews in the new Rhino opening screen are also now black.

Software information

Software versions
Rhinoceros version: 5.0 Wenatchee 2014-05-20 (514)
OS X version: Version 10.9.3 (Build 13D65)

Plug-ins
/Library/Frameworks/3DconnexionClient.framework/Versions/A/3DconnexionClient

Hardware information

Computer hardware
Hardware model: iMac13,2
Processor: Intel Core i5-3470S CPU @ 2.90GHz
Memory: 8 GB
Architecture: Intel 64 bit

Video hardware
Graphics: NVIDIA GeForce GTX 660M 512 MB
Memory: 512 MB
Screen size: 2560 x 1440
Displays: iMac

Third party kernel extensions
com.3dconnexion.driver (10.1.1)
com.avatron.AVExVideo (1.7)
com.avatron.AVExFramebuffer (1.7)

USB devices
Western Digital: Elements 10A2
Apple Inc.: FaceTime HD Camera (Built-in)
Apple Inc.: Apple Keyboard
3Dconnexion: SpaceNavigator
Western Digital: Ext HDD 1021
Apple Inc.: Bluetooth USB Host Controller

Bluetooth devices
None

OpenGL information

OpenGL software
OpenGL version: 2.1 NVIDIA-8.26.21 310.40.35f08
Render version: 2.1
Shading language: 1.20
Maximum texture size: 16384 x 16384
Z-buffer depth: 24 bits
Maximum viewport size: 16384 x 16384

Implementation settings
Use texture compression: No

Appearance settings
Antialiasing: None
Mip map filtering: None
Anisotropic filtering: None


#2

I’ve seen this and reported it in the past but still haven’t figured out a way to make it happen on demand.

what I’ve been doing to get the previews back is to quit rhino… relaunch & open the blacked out files… press cmmd-S…
this saves a new version and will usually update the icon to a picture


#3

Jeff, I thought someone had seen this recently, but that it had been sorted! Just tried the cmmd-S trick; it seemed to work for a brief second during the Rhino launch screen, but then the preview reverted to black.

I’ve also noticed that when loading a file I temporarily get a solid black rectangle instead of the 4 view while the file is loading. I don’t recall seeing it before, but it could be that I’m just looking for it now.


#4

seeing the black when opening is normal (if the thumbnail is black)…
the first second or two of a file opening shows the preview image instead of the viewports.

or, if that’s not considered ‘normal’ , it’s been that way for as long as I can remember.


it’s probably hard to get it sorted because I don’t think marlin has been able to reproduce it yet.

if you can figure out a way to make it happen (steps required, certain display modes, etc) then please share :smiley:

for me, I can still only say it happens randomly.


#5

Cheers, I understand about the loading screen now. Have restarted machine but the issue remains; will keep an eye out and see if I can work out how to reproduce the fault.


#6

Doing more work on files that previously had a black preview, when exiting the file after making changes the file preview has now appeared! Will try and reproducing loosing it again…