Minor bug- blank layers and osnap panel when launching file


#1

I’ve just downloaded the latest Mac Rhino WIP release. Launching Rhino by clicking on the main icon (i.e. not from double clicking a saved file) works as expected. However, if I then launch another file using file>open or open recent the file is launched normally but the open layers panel and osnap panel are completely blank apart from their titles. Closing and reopening the panels updates them. I’ve tried a number of different files and it happens consistently.

Software information

Software versions
Rhinoceros version: 5.0 Wenatchee 2013-08-15 (472)
OS X version: Version 10.8.4 (Build 12E55)

Plug-ins
/Library/Frameworks/3DconnexionClient.framework/Versions/A/3DconnexionClient

Hardware information

Computer hardware
Hardware model: iMac13,2
Processor: Intel Core i5-3470S CPU @ 2.90GHz
Memory: 8 GB
Architecture: Intel 64 bit

Video hardware
Graphics: NVIDIA GeForce GTX 660M 512 MB
Screen size: 2560 x 1440
Displays: iMac

USB devices
Western Digital: Elements 10A2
Apple Inc.: FaceTime HD Camera (Built-in)
Western Digital: Ext HDD 1021
3Dconnexion: SpaceNavigator
Apple Inc.: Apple Keyboard
Apple Inc.: Bluetooth USB Host Controller

Bluetooth devices
Apple: Apple Wireless Trackpad

OpenGL information

OpenGL software
OpenGL version: 2.1 NVIDIA-8.12.47 310.40.00.05f01
Render version: 2.1
Shading language: 1.20
Maximum texture size: 16384 x 16384
Z-buffer depth: 24 bits
Maximum viewport size: 16384 x 16384

Implementation settings
Use texture compression: No

Appearance settings
Antialiasing: 4x
Mip map filtering: None
Anisotropic filtering: None


Layers at start won't show
Cplanes Gone in Existing Files 20130815 WIP
#2

I’ve just tried to take a screen shot, and found that by taking the focus off of Rhino and then back again updates the two panels.


#3

This was happening to me as well, running OSX 471, just updating to 472 (15 AUg release). I will see once I restart.

Still happening here. Better open discourse on my Mac, so I can add OpenGl info.

Software information

Software versions
Rhinoceros version: 5.0 Wenatchee 2013-08-15 (472)
OS X version: Version 10.8.4 (Build 12E55)

Plug-ins
None

Hardware information

Computer hardware
Hardware model: iMac12,2
Processor: Intel Core i5-2500S CPU @ 2.70GHz
Memory: 4 GB
Architecture: Intel 64 bit

Video hardware
Graphics: AMD Radeon HD 6770M 512 MB
Screen size: 2560 x 1440, 1280 x 1024
Displays: iMac, BenQ T701

USB devices
Staples: Relay UFD
Apple Computer, Inc.: IR Receiver
Apple: Internal Memory Card Reader
Apple Inc.: FaceTime HD Camera (Built-in)
Apple Inc.: Bluetooth USB Host Controller

Bluetooth devices
Apple: Apple Magic Mouse
Apple: Apple Wireless Keyboard

OpenGL information

OpenGL software
OpenGL version: 2.1 ATI-1.8.18
Render version: 2.1
Shading language: 1.20
Maximum texture size: 16384 x 16384
Z-buffer depth: 24 bits
Maximum viewport size: 16384 x 16384

Implementation settings
Use texture compression: No

Appearance settings
Antialiasing: 4x
Mip map filtering: None
Anisotropic filtering: None

randy


(Marlin Prowell) #4

I see this. This will be fixed in the next WIP release. As a workaround, open a empty model with Command-N, and this will “wake up” the auxiliary panels.


Named views Panel doesn´t show entries
#5

Same Problem for “named views” panel.

Your hint (open new empty file …) doesn´t help here …

original entry:


Named views Panel doesn´t show entries
#6

i usually just click outside Rhino, then back, for the panels to ‘appear’. I am working with 2 monitors, so it makes it easy to click on say a Finder Window then back to Rhino. Works for me.