Rhino 5.5.2 Cannot Open Files

I am not able to open any of my Rhino files in the most recent version of Rhino. The file keeps loading but doesn’t open.

I tried deleting Rhino Preferences and restarting Rhino but that didn’t help. I then uninstalled Rhino and downloaded a fresh copy but still no progress.

My software and hardware details are below:

Software information

Software versions
Rhinoceros version: 5.5.2 (5F85)
Rhinoceros path: /Applications/Rhinoceros.app
IronPython version: not installed
Language: en-US (MacOS default)
macOS version: Version 10.14 (Build 18A391)


Third party kernel extensions
com.symantec.kext.internetSecurity (5.2.2f12) BD0ACF56-FC15-3325-92A6-2493D52C2D89
com.symantec.kext.ndcengine (1.0f2) no UUID
com.symantec.kext.ips (3.5.1f12) no UUID
com.symantec.kext.SymAPComm (100.1f12) 4D8A9157-A274-3480-85E2-C1F20A81AD1E

Hardware information

Computer hardware
Hardware model: MacBookPro14,1
Processor: Intel Core i5-7360U CPU @ 2.30GHz
Memory: 16 GB
Architecture: Intel 64 bit

Video hardware
Graphics: Intel Iris Plus Graphics 640 1536 MB
Memory: 1536 MB
Screen size: 1440 x 900, 1920 x 1080
Displays: Color LCD (256dpi 2x), ASUS VE276 (82dpi 1x)

USB devices
Microsoft: Microsoft 3-Button Mouse with IntelliEye™
VIA Technologies Inc. : USB 2.0 BILLBOARD
Generic: USB3.0 Card Reader

Bluetooth devices

OpenGL information

OpenGL software
OpenGL version: 2.1 INTEL-12.0.34
Render version: 2.1
Shading language: 1.20
Maximum texture size: 16384 x 16384
Z-buffer depth: 24 bits
Maximum viewport size: 16384 x 16384

Implementation settings
Use texture compression: No

Appearance settings
Antialiasing: 4x
Mip map filtering: None
Anisotropic filtering: None

Hi @premnats-

Sorry for the delayed reply. It looks like you have quite a few third-party kernel extensions installed. Can you please try booting macOS to Safe Mode (which disables these extensions) and see if the problem persists?