Failed to load Revit Grasshopper components

Hi, I install rhino inside as the constructions, but I get into some errors like below.
image


I can use Sample 1. But there is no commponents for other Sample.
Actually, Most Grasshopper components failed to load.





An error occured during GHA assembly loading:
Path: C:\Users\Administrator\AppData\Roaming\Autodesk\Revit\Addins\2017\RhinoInside.Revit\RhinoInside.Revit.dll
Exception System.IO.FileLoadException:
Message: The located assembly’s manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)
Rhino inside is a wonderful idea as I thought when I first get learned to use Grashopper. You just realesed it in open souce code. That’s a great thing!

I just checked the Grasshopper.dll referenced.
Version In my Rhino WIP.:
Grasshopper, Version=7.0.19289.23125, Culture=neutral, PublicKeyToken=dda4f5ec2cd80803
Version of the RhinoInside.Revit.dll referenced:
Grasshopper, Version=7.0.19183.10490, Culture=neutral, PublicKeyToken=dda4f5ec2cd80803
I don’t know if it’s that reason.



It seems I use too high version Rhino7
But if I use lower version.It shows
image

Anyone can help? Than you in advance.
@DavidRutten

Just to be sure we are using the same version of Rhino, Grasshopper and RiR, please install the last version of everything.

Rhino 7 WIP: https://www.rhino3d.com/download/rhino/wip
Rhino.Inside Revit: https://www.rhino3d.com/download/rhino.inside-revit/7/wip

Now please test it loads normally from the desktop, not inside Revit.
Also would be helpful to know which version of Revit are you using and if your Windows is also configured in Chinese.

Thank you Mr Garcia. I use Revit 2017
It seems you paste same url for Rhino 7 WIP–
Yes, My windows configured in Chinese.

Hi,

I’ve updated the Rhino WIP download link on the previous post.
Did you have a chance to test with the last version of everything?
I tested it here and works.

I didn’t test changing the Windows language to Chinese, but Revit and Rhino only.
I see in your screenshot that you have 2017, mine is 2017.2.
I don’t know if this makes the difference but it is worth to try to update.

Thanks ,I will try it.

@kike

My Rhino was updated today to latest version this cause my grasshoper not to load any more.
Version: 7.0.19351.11415, 17/12/2019
image

here is error


how to fix it? your advice will be appreciated

I can see file in correct place…hmm

I downloaded code from GitHub rebuild myself but still the same issue

@michaldengusiak
I updated my Rhino WIP to latest and tested. The issue does not appear on mine. Everything loads okay under Revit 2019 and 2020

Would you mind disabling your other Revit and GH addons and load a clean Rhino.Inside? Maybe there is a conflict somewhere

@eirannejad solved!
Yes, without anything else it worked. I will go one by one to check which one is causing issue. and delete all unwanted files.

1 Like