Extrusions, Lofts and offsets from curve will not extrude as solid. Cannot Cap either


I am trying to recreate the pod section of the ring in the image. I have drawn the pods out as a flat curve and bent them around the inner circle of the ring. I intended to extrude the curve out solid and booleon the indentations in for the stone settings. However, every attempt to do so is met with the same error, this uncapped shape.

I have tried offsetting the curve from a surface, sweep 2 rails and loft. All are met with the same result.
When I attempt to cap the shape, it says “unable to cap one object, object did not have closed, planar loops of edges.”

When i try to join the curves, it says ‘cannot join closed curves’ … and zooming in shows nothing wrong. so why is it saying it is both closed and unclosed at the same time… this isn’t Schrodingers curve.


Can anybody help me? or suggest a better way of achieving that shape?

I have managed to cap the object using the ‘Edgesrf’ command and joined the surfaces. Now a new problem arises. Every type of attempt at a booleon fails. difference, intersection, union and split.

Cap will only work if the holes are closed and planar. The latter part appears to be what was missing. It sounds like you got that issue sorted but if you had a circular curve of the same diameter in the side or front view, you could also extrude it and split that surface with your existing curves to get the top surface.

For the Boolean issue, it looks like the problem may be the coincidence of the surfaces or something might be open. You could try a small scale of the shank from it’s center to test if the coincident cylindrical surfaces are the issue. Post the 3dm if you can if that doesn’t help.

Hi Brian, Thanks for the reply.

I managed to sort the Boolean Issue by extruding a copy of the pod section in both directions and that worked. So I think you are right and that the surfaces were too close.

I have however run into further issues haha. I am currently trying to fillet the outer edges of the pod section. However when I do, it just creates lots of overlapping surfaces all along where the fillet should be. I am quite stumped as to how to approach this problem. I forgot in the early stages of modelling to fillet the corners of the end pods, so perhaps thats giving me an issue. Ive taken some screenshots that ill add in below, and the .3dm if i can.

Rhino_Ring__001.3dm (6.7 MB)

There are number of naked edges and overlapping surfaces in that polysrf which need to be repaired for the fillets to work well.

Here’s a video of the process…

1 Like

Hello again Brian, Thankyou so much for your help! That video was wonderful.

I realized that I couldn’t fillet the bottom edge of the pods because I had booleoned out the pods from the Shank, leaving a V which is revealed if I fillet the bottom edge.

I have rebuilt the shank so the inner surface of both the ring and the pods are flush. Is there a way that I can merge them together so that I could fillet the entire inner edge of the ring so that the shank and pods flow together? As well as remove the top half of the ring that intersects with the pod openings?

Also I am trying to make a Sphere sunk half way into the surface do an Array around the pods. I am trying to use Array Surface, but I cant think of a way to draw the control curve onto the surface. In hindsight I should have added the guideline in the 2D before I began. The spheres i have there at the moment are just place holders to give you an idea of what i am trying to achieve.

Rhino File:

Rhino_Ring__002.3dm (7.1 MB)

Thank you so much for your help again, it means a lot. I am quite new to Rhino, and thus keep running into problems i hadnt thought of. so I feel guilty that what was meant to be a thread to solve a problem has turned into a tutorial haha. I am learning alot though. It is greatly appreciated.

For the bead detail I’d use ArrayCrvOnSrf. Here’s a video showing how to get the curve path too…

The smooth transition modeling could be accomplished with these techniques…

This is great thankyou!

I have the bead detail down. Im having trouble with the pipe and trim however. I’ve followed your steps to the letter but this little bit of the shank thats poking through the pipe refuses to be trimmed. ive tried extending the pipe beyond it, moving it and setting a different diameter but it still refuses to budge. So im not sure what is going wrong. is it something in my settings that differs to yours perhaps? as ive gone through the video a few times and repeated the steps each time and i have the same result.

Nevermind! I managed to sort it. When I divided the ring into two, so i could work on a half model. I deleted the opposite side to the one you did. So for some reason that affected everything that went after. Im not sure if its because there was a minor discrepancy in the other half or something. But I have now successfully managed to trim that piece.

Nice work… yes, the other side may have had a small difference. One other thing to think of next time you see that is to use ExtendSrf on the edge of the pipe surface to make it extend past what you want to trim a little. I bet that’s where the issue was.