Extrude with split at tangents option bug

If I extrude this line with ‘splitattangents=yes’ then the resulting surface is split, but the input curve is just one simple curve so I don’t see why it would result in a split surface.

The curve is from an edge of a surface (hidden in same file.)split at tangents bug 2.3dm (44.9 KB)

The curve does have one multiple knot in it (try _RemoveMultiKnot) and as the curve is almost straight, it looks like Rhino considers it a tangent joint - your angle tolerance is set at 1° so it’s entirely possible. If you remove the multiple knot, you get one surface.

Thanks. But I don’t think that’s what the option is supposed to do, according to the help:

“Create a polysurface when the input curves are joined tangent curves. Faces in the resulting polysurface correspond to the tangent sub-curves in the input curves.”

Also, the help file seems to have the ‘yes’ and ‘no’ options switched.

Yep, agreed, it’s an odd case. Also V6 does not seem to behave this way… @pascal?

I think v6 didn’t work correctly either, because it didn’t split where the input curves were split, instead splitting only if the curves were specifically not tangent (it didn’t split in the case of curvature continuity). I pushed for them to change that to match the input curves, and it’s a big help. But this case doesn’t seem right (but if splitting at knots instead of where curves come together is the price for the rest of it working as it is, then I’ll take it.)

The curve is ever so slightly twisted at that location -

I guess that is why this splits, in conjunction with the other change you mentioned…