Extrude curve to boundary unreliable


#1

I stopped using this option a long time ago because in my experience it rarely works… :confounded: Why?

Attached a very simple example I tried this afternoon…

–Mitch

ExBoundFail.3dm (69.3 KB)


#2

fwiw, that works for me (sort of)… i did find something a little weird though–

if i select the curve (either before or after running the command) and i don’t move it with the cursor prior to choosing ‘To Boundary’, i’ll get an error- “One input was not extruded because it would have made an invalid surface.”

if i move the curve a little (previewing the extrusion) with the cursor prior to choosing To Boundary, it will work as expected.

??

are you able to duplicate this behavior as well Mitch?


#3

Nope… The command line just says the following:

Select curves to Extrude. Press Enter when done: Extrusion distance <0> ( Direction  BothSides=No  Solid=No  DeleteInput=No  ToBoundary  SplitAtTangents=No  SetBasePoint ): ToBoundary Select a boundary surface ( Direction ): Splitting... Press Esc to cancel

–Mitch


#4

OK, now I see something - you are right, it is the on-screen direction of the extrusion that is causing the failure (good catch!). As I have the command line on the bottom, if I go to click the option on the command line, it fails (as it is pulling the extrusion downwards), if I pull it upward and just type the option, it works. And yes, if I don’t pull it at all I get the error message you indicated.

So, this is totally buggy - it should absolutely NOT depend on what’s on the screen…

–Mitch


(Pascal Golay) #5

Hmmm- I cannot make it fail so far.

-Pascal


#6

try not moving the preview surface…
on mac, do exactly the following:

• type ExtrudeCrv (return)
• select the curve (return)
• type ‘t’ (return) [‘T’ being the To Boundary option]
• click on the surface

this should give you the error i reported earlier.

likewise, if i do use the mouse to preview the extrusion and i preview it downward (whereas the boundary surface is in the positive direction) then use the ‘to boundary’ option, the extrusion will fail… i have to have a preview of the extrusion going in the direction of the boundary surface in order for the command to work properly


#7

@pascal : just in case you haven’t been able to reproduce this…

video

–Mitch


#8

Weird. Just did the exact same thing as in the video and it is working here. Tested it with typing the command and in the menu. With typing T and clicking it. :open_mouth: I can’t reproduce this :frowning:


#9

Is your command line on the top or bottom?

–Mitch


#10

on the Top. Maybe that can be the cause… ill check it…

Oke on the bottom it bugs as well xD
and the thing is… when I moved it from bottom to top again and use T to use the boundary thing. It didnt work until I clicked the command in the command bar again. Next time when typed T. It worked again.

Sorry. So bad English there xD but hope you can understand what I’m saying