Export Rhino dwg no way to have high mesh


I tear my hair out.
I model under Rhino 6, export in dwg to rework in 3ds max.

When exporting dwg, I choose the schem: 2007Solids
and the maximum of polygons in the mesh option.

when I do the test with a sphere it works very well.
When I export one of my parts I get a low mesh.
Rhino’s analysis tools are not telling me anything.
Do you have an idea ?

Best regards

Try FBX files and use the mesh options to crank up the number of faces.


Thank you for your answer, I would have preferred to keep the dwg to import link in dwg,
but even in fbx it gives weird things.

You want to send us an example? There are many things that can confuse to transfer. For instance the distance of the object from the origin. Or the overall size of the object.

The trick to real control of the mesh is to use the Detailed controls at this dialog:

And make sure the DWG export options are set to export surfaces as meshes. This is an example dwg to see if it works in 3DSMax:

wheel1.dwg (10.4 MB)

Hi @scottd

Your wheel spins perfectly well under 3ds max.

I use the polygon mesh option which I use as much as possible, despite that I only have a low mesh.
Looked at the 2 links in my first post, you will find the screenshot of my export setting, as well as my .3dm

Thank you for your help

This morning uninstalled reinstalled Rhino, it’s exactly the same.
The only good result is to export to fbx.
but i would like to understand what is wrong with my dwg

See down below the result : (

Hello @John_Brock

I take the liberty of addressing you concerning the quality of the dwg export, indeed a lot of exchange seems to encounter difficulties.
What is your point of view ?


It is great the the process works with the wheel. No we just need to get the settings correct on your Rhino to get the same results.

When exporting, I use a custom DWG export typr. At the DWG time you can go to Options and then edit schemes. I set the Export Surface as property to meshes.

Then Save that.

Now on export the Polygon Mesh settings come up. GO to Detailed Control. There is all the advanced control.

I like to set minumum initial grid quads high, say 1000+ for this situation. There are many other options.

Use Preview button to see the results. Then when it is right, press OK. Results attached.

widget2.dwg (12.8 MB)

Hi @scottd

I risk exhausting your patience, but I tell myself that it can be useful to others.

Indeed your technique improves things, but appears jagged edges.

I thought this was your a bad import in 3ds max, but viewed in DWG true view, the result is the same.

I tried to decrease the initial minumum grid quads setting from 1000 to 500, but it’s the same.

Any idear ?

This model just need some clean up. While it currently is working correctly as built, it may not be exactly configured in the way you need it. Some clean up areas I would look at are:

Can I ask how large this part is supposed to be? I see the model is in meters and the detail you are showing is getting down dangerously close to tolerance. Down around tolerance detail will be lost.

For instance the Tools units tolerance is set to 0.01 meters. But those edge details you show are in the range of 0.002146 meters. This is below tolerance.

A part this small I would run in mm.

Also, this model is a series of solids that are not booleaned together as on solid. Is it supposed to be one solid object?

In fact, this is the part of a bridge that I’m trying to rebuild, to produce animations in 3ds max.
In no way is my approach technical.
I launched into Rhino from a meter template.

Hope it’s a solid. I proceeded by extrusion. do you think I should have done that boolean?

Having followed this thread more or less (maybe I missed something), IMO the best way to guarantee a good mesh on export is to first mesh the objects in Rhino, then export the meshes. That way you can check the results before you export and if necessary mesh certain pieces with different parameters until you get what you want.

1 Like

Yes, but tolerance is set to 0.01 meter. I expect you are probably concerned about measurements that are smaller then that.

You could set tolerance to 0.0001 or less if you want. Then more accurate meshes will be possible.

I agree with @Helvetosaur - that meshing to a new layer might be the best route to check what is meshed saved out before writing the DWG.

You are probably right.
What I do not understand is that a few months ago I had an export with the standard settings and that everything had been successful.
From what you tell me, I will redo the tests, the constraints being that the final assembly is not too heavy. I only need to zoom in on certain parts.

Hi @scottd, @Helvetosaur

After many tests, I arrive at partial results.
When I decompose a block, I get an acceptable smoothing.

  1. Unfortunately I don’t understand why

  2. So, Rhino finds me bad objects, which he didn’t do before, whic.

  3. If I decompose my whole assembly, I end up with a .dwg file of almost 500MB, wich crash 3ds max.

Do you have an explanation.

Image: below, entire block, above the same decomposed block

Thank you in advance for your patience.


Denis -

What are the units and tolerance on that large file you are showing us? https://wiki.mcneel.com/rhino/faqtolerances

The Mesh settings are critical to get right: https://wiki.mcneel.com/rhino/meshfaq

If 3DSMax has a limit on import size, splitting up the DXF export is another option. You could split certain sets of layers into specific DXFs.


I have copied the items to a new file.
Unit: centimeter
Absolute tolerance: 0.01

For the decomposed block, I get:
Edge tolerances: from 0 to 0.0330583
median = 0 mean = 0.00368527
um, that seems pretty high, doesn’t it?
How can I change this tolerance?

For the second object, the block, I cannot find a tolerance.

Just select the couple objects you are working on and do export selected. Then send us that.

There is still something not quite right about the units.

metalcross_good_wrong.3dm (16.5 MB)

I’m already starting to hunt for the wrong object