Excel Table in Layout

I have to insert an Excel table in a layout, but can’t seem to find a way to do so. For example, on a layout, I have to have a table showing Find No, Item Name, QTY, and Part Number. There can be up to 25-30 individual parts I have to do this for per drawing. What would be the best way to approach this, or what would be a good resource for me to learn how to do this. Thanks for any help!

A few options:

  • PrintScreen from Excel and place that image in Rhino.
  • Use Grasshopper to import the Excel file and do your formatting (column width and row height, …) in Grasshopper.
  • Use the RhinoPiping plugin to import a csv as a table.

(for a Discourse discussion on this topic with more background - see this thread).

1 Like

Awesome! Thanks so much for your help. I’ll take a look and post my results this morning. Thanks again!

Do you know if there is any other way to download the free table plugin from rhinopiping? Their site seems a bit on the fritz… very laggy for me, I’ve created account and added to cart but just get error when trying to complete the transaction.

while not a direct answer. I had the same issue. I wound up using chrome, then create an account, then order it. I had to do this 4-5 times before it worked. The screen didn’t look like it worked, but they emailed me with a link to download. I have sent them an email describing the issue. If you want, I can post the link when I get back to my PC.

I quit after the 3rd try.
I’ve been in touch with Matthieu from Navinn. He directed me to a foodforrhino link, but that seemed to be only for the official rhinopiping plugin, which although interesting looking is not what I’m looking for right now…
Any chance you can share your download link for the free table plugin? Maybe it will work for me…

Posted the link, then was notified the link is linked to my account. Sorry. If it helps, I just got a BUNCH of emails from them, each with a new link to the file. Unfortunately, they are all associated to me, but hopefully you get the same shortly. If not, I will post it in my OneDrive for you to download. I just don’t want to cause any issues with them by sharing a link associated to my account.

Edit again. Here’s the link to my OneDrive. Please let me know when you download it, so I can remove the link. I don’t want to Bo Navinn wrong, since they were nice enough to make a free plugin.

Hi, sorry for the website issues you experienced back then.
For information, a brand new website has been designed and published since then (At the beginning of February 2017) , nobody should have this kind of issue anymore. There is also a website dedicated for support.

Link for the table plugin: http://navinn.rhinopiping.com/table-plugin/

Best Regards
The RhinoPiping team

Just tried using the plugin for importing csv tables, just freezes Rhino and then have to force quit the programme :frowning:

Are you using Rhino5 or Rhino6?
The table plugin is not developed anymore as an independent product but integrated in our premium tool RhinoPiping Pro+. Anyway I’ll try to debug it a little bit when I have some time, hopefully I will be able to solve your issue.

Hi, thanks for the reply. Using Rhino 5 here, I was hoping to just use the import csv table option :frowning:

Maybe it’s time to ask for a McNeel proper solution to address this issue, as we miss more and more such basic functions in Rhino. It’s so difficult to use undeveloped 3rd party plugins!


Hi Matthieu, any news on the CSV table plugin ?

Not yet unfortunately, we are short on staff at the moment.

I’ll let you know when I have some time for an update. (Or you can ask
on the website for a RhinoPiping Pro trial, it comes with a rhinopiping
pro+ trial license, wich includes a more recent version of the table

Best regards

Hi Matthieu, yes have installed a trial so I can try out importing CSV tables onto layout pages.
When I bring the file in it doesn’t seem to keep the column structure ? It is just single row of information, not spaced out ? Am I missing something ?

A single row of information occurs when the csv could not be read correctly.
Please check your decimal separator and try to save your csv with UTF8 encoding, that should fix this problem.

This doesn’t seem to solve the problem :frowning:

Hi @milezee @Macuso @wim @carvecream @djordje ,
Here is a new version that let you insert tables from a .xslx file.
This is a limited version, without editing features but it works fine for those who had issues with csv.
Best regards


(The command is TableV2Beta )

Thank you for the new version. Still not working as expected in Rhino6.

TableV2Beta_Rhino6_test.zip (4.3 KB)