ESC key fails to abort

abort
mac

#1

In the windows version, the ESC key aborts the current operation. In the Mac version the “press ESC to Abort” message is shown, but pressing the ESC key does nothing. I’ve lost count of the number of times i’ve had to force quit rhino and restart because of this.

This has been the case for as long as I’ve been using Rhino for Mac (several years).

Can this be fixed?


A more robust Press Esc to cancel?
#2

Have you been using the same hardware the whole time? I had a problem with my wireless keyboard vs my laptop keyboard where the delete key did not work on the laptop while both the delete and del keys worked on the wireless keyboard. I reported this but could get no help (as no one else had ever reported it). I was lucky it went away after a few days and has not come back. So you could try different hardware. Or maybe there is another alternative; the shift+! key combination will also abort the current command. This avoids your potentially faulty ESC key and hopefully works in the Mac version (I am using the Windows version).


#3

There are two behaviors that I have always observed the esc key. In the first case, for example, if I use the command line, I click and then if I press esc cancel the operation. In the second case if such step from wireframe display in pen and I press send, by pressing Esc does not cancel the operation (and in fact for years that during the operations of this kind the only solution is forced out)


#4

Does the ESC key work otherwise or not at all? On the PC other programs(usually from Adobe)can monopolize certain keys. A quick search reveals this sort of thing can happen on Macs too, though you may have some work to track down the culprit. Another cause of hassle which also exists on Macs can be “accessibility” features that mess with keyboard input and can easily be accidentally activated.


(Dan Belcher) #6

Hi @anomalous-

Sorry for the delayed uptake here. Hrmmm. I’m not able to reproduce this on my computer. Can you give detailed steps? You say it’s happening all the time, so I guess I’m having trouble figuring out where to test first.

The behavior that @Zsimon is reporting…

wireframe display in pen and I press send, by pressing Esc does not cancel the operation (and in fact for years that during the operations of this kind the only solution is forced out)

I believe we already have on our TODO list as a known bug.


#7

just had to force quit rhino after using ‘flow along surface’ , esc did nothing


#8

i never found that esc cancels anything, once the computer starts howling while working hard on complex intersections etc.


#9

yep true, I found esc works for getting out of simple commands, when drawing curves etc, but once you start a more complex surface command it doesn’t escape anything, usually end up having to quit rhino and restart


#10

If I had not explained here more details: For example, use the command “Intersect” on complex objects, and Rhino does not respond, use the ESC command to cancel the operation does not work. I use the pen display often and, if the model is “heavy” it can take several minutes for the command to work, even in this case, press ESC to cancel the operation does not work.


#11

exactly


#12

In my experience, there are two ways the ESC key fails. The first is trying to abort any command that is non-instantaneous. maybe an intersect, maybe a make2d, a patch, anything that involves a lot of objects. in short, anything you might want to escape from (most likely because you didn’t realise it was going to take so long)

the other fail is something that happens less frequently, and which is more likely an incidental effect of a larger fail - ie the complete freeze of rhino when trying to do what should be a very simple command - an intersect between two or three simple objects.

I have had this happen on two or three different computers, and my colleagues also have the same issues. my current machine is a high end i7 macbook pro with 16gb of ram. the amount of processing power or memory seems to make no difference. once you’ve started a compute intensive operation, the ESC key fails to abort. I run both windows and macos on the same machine, and the windows version of rhino has never had this problem. I should also note that I mostly use the WIP version of Rhino for mac, though the problem exists in the release version just as badly.


#13

I have been thinking about asking this same question for months.

I’ve never seen stop anything.


#14

what would also be nice is when using Emap or Zebra to press the esc button and move on to the next command, at present you have to click ‘done’ in the pop up dialogue box to finish either of these commands,


(Dan Belcher) #17

Ok, now we’re getting somewhere. Can you please provide a file with an intersect that takes a really long time on your machine?


#18

If the file is super heavy, I’ve seen similar behavior in Win Rhino too. ESC just takes a while to cancel an operation.

Just today, we,were evaluating a top spec Paperspace instance, and using Rhino as one of the tests, using a very heavy 500MB file with a gaziillin rounds. ESC took a while…

Paperspace works great with CAD apps BTW.

https://www.paperspace.com/


#19

Hi @dan
Right now I’m working almost completed files and I can not share them in any way. However I will try to find a model where I can reproduce the problem and send. Once again, I apologize for not being able to share certain files, pictures or videos of them, as this does not help solve the problem.
If I remember correctly, in the past I had done an intersection test with “bad objects” and always failed or blocked Rhino (without being able to come out with “undo” or “esc”.

Simon


#20

actually it is when the command window it still active, once you click on something else the window becomes inactive just not right click so rotating the camera still works keeping it escapable, which generally is also not so bad since zebra enables to analyze surface while point editing it which itself is escapable.

but something like a quick double pressed esc to escape all generally escapable but remaining open windows, would be interesting.


#21

yes would be nice, but to be honest, and back to the esc button, if it just worked when trying to escape commands would be a great start :slight_smile:


#22

Hmm, sounds like what you mean is a ‘master’ ESC that instructs the software to just end whatever task it is up to immediately, no matter what, and return to the open state??? (If technically possible?)

Thinking back, when I’ve experienced Rhino seemingly ignore ESC, on both Win and Mac, it is usually when in the process of calculating something that will take Rhino significant time anyway, such as generating a render mesh on a heavy file, or processing a lot of fillet edges at once, or something pehaos as @Zsimon describes, where Rhino is in “deep thought…”


#23

or even better to keep the windows addressed sequentially, that when point editing is opened after zebra for example, that esc would quit points and another esc would quit the last remaining. i thin not being able to cancel zebra with esc could also be considered as a bug in this context.

can also be, but a simple esc to quit a deep thought and also other open commands should suffice. i meant just in case of several windows open which have to be canceled separately a double esc, but maybe the described sequential idea would be better since this would be rather in the manner of how rhino works actually.